summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2023-09-02 08:22:53 -0400
committerAlyssa Rosenzweig <alyssa@rosenzweig.io>2023-09-02 15:43:18 -0400
commitc38b67f4d1abe7b137b24dbfa4aaf0be46c2b193 (patch)
tree878162ad583b5fec9d4c438e539120fbfa11397b /meson.build
parentfd114ab7068aab2a71c431fb0c96e1f7fb78e9bd (diff)
downloadmesa-c38b67f4d1abe7b137b24dbfa4aaf0be46c2b193.tar.gz
mesa-c38b67f4d1abe7b137b24dbfa4aaf0be46c2b193.tar.bz2
mesa-c38b67f4d1abe7b137b24dbfa4aaf0be46c2b193.zip
intel: Limit Intel Vulkan RT to x86_64
Note: passed CI repeatedly except for the timing out WHL jobs. Fixes: 28c1053c07c ("intel: Allow using intel_clc from the system") Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/25009>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 75c4d3859b8..0aa07eb08d7 100644
--- a/meson.build
+++ b/meson.build
@@ -253,10 +253,11 @@ with_any_broadcom = [
if ['x86_64'].contains(host_machine.cpu_family())
with_intel_clc = get_option('intel-clc') == 'enabled'
+ with_intel_vk_rt = with_intel_vk and get_option('intel-clc') != 'disabled'
else
with_intel_clc = false
+ with_intel_vk_rt = false
endif
-with_intel_vk_rt = with_intel_vk and get_option('intel-clc') != 'disabled'
with_any_intel = [
with_gallium_crocus,