summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuc Ma <luc@sietium.com>2023-04-14 18:53:57 +0800
committerMarge Bot <emma+marge@anholt.net>2023-04-14 23:16:01 +0000
commitb5a9021708d87d17538e0e27fe4ad6a5e20fa9a9 (patch)
tree5563790ee9418c1cd4d0c915865671b7a436a6f5 /meson.build
parent8f0da0851f299aca00a2d9ec6e64b565a18eeeaa (diff)
downloadmesa-b5a9021708d87d17538e0e27fe4ad6a5e20fa9a9.tar.gz
mesa-b5a9021708d87d17538e0e27fe4ad6a5e20fa9a9.tar.bz2
mesa-b5a9021708d87d17538e0e27fe4ad6a5e20fa9a9.zip
meson: keep Mako version checking in accord with build msg
Fixes: 52194ae4df1 ("meson: Ensure that mako is >= 0.8.0") Signed-off-by: Luc Ma <luc@sietium.com> Reported-by: Terry Zhang <terry@sietium.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/22499>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a3e3c5478a8..c7a4be82e59 100644
--- a/meson.build
+++ b/meson.build
@@ -848,7 +848,7 @@ has_mako = run_command(
'''
from distutils.version import StrictVersion
import mako
-assert StrictVersion(mako.__version__) > StrictVersion("0.8.0")
+assert StrictVersion(mako.__version__) >= StrictVersion("0.8.0")
''', check: false)
if has_mako.returncode() != 0
error('Python (3.x) mako module >= 0.8.0 required to build mesa.')