summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFaith Ekstrand <faith.ekstrand@collabora.com>2023-08-03 18:32:45 -0500
committerMarge Bot <emma+marge@anholt.net>2023-08-04 21:32:07 +0000
commit8c62b3938a89a60baf56ebdbfb6b85157993ab2a (patch)
tree5234739b936ce71557827946e34d2b584be9da33 /meson.build
parentb2fe4c772953cbce27df46e0368f160e5a0be820 (diff)
downloadmesa-8c62b3938a89a60baf56ebdbfb6b85157993ab2a.tar.gz
mesa-8c62b3938a89a60baf56ebdbfb6b85157993ab2a.tar.bz2
mesa-8c62b3938a89a60baf56ebdbfb6b85157993ab2a.zip
nvk: Enable the new UAPI
We also add a meson option to disable it and re-enable the legacy API. This code probably won't last long but it gives developers the option. Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/24326>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 248eadf1398..83f4e9cf66d 100644
--- a/meson.build
+++ b/meson.build
@@ -261,6 +261,12 @@ with_any_intel = [
].contains(true)
with_any_nouveau = with_gallium_nouveau or with_nouveau_vk
+if with_nouveau_vk and get_option('nvk-legacy-uapi')
+ pre_args += '-DNVK_NEW_UAPI=0'
+else
+ pre_args += '-DNVK_NEW_UAPI=1'
+endif
+
if with_swrast_vk and not with_gallium_softpipe
error('swrast vulkan requires gallium swrast')
endif