summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmma Anholt <emma@anholt.net>2023-06-05 16:20:55 -0700
committerMarge Bot <emma+marge@anholt.net>2023-06-12 21:37:37 +0000
commit1dd1147408e8fcfb9cbd08d5a5651152d288ef41 (patch)
treead5dca315c866a11f280afb0ab07e56dad8bce89 /meson.build
parent34808de7371f93222136994a8656fc21b55bdd65 (diff)
downloadmesa-1dd1147408e8fcfb9cbd08d5a5651152d288ef41.tar.gz
mesa-1dd1147408e8fcfb9cbd08d5a5651152d288ef41.tar.bz2
mesa-1dd1147408e8fcfb9cbd08d5a5651152d288ef41.zip
mapi: Delete execmem support code.
No longer used now that we don't dynamically generate dispatch stubs. Acked-by: Marek Olšák <marek.olsak@amd.com> Acked-by: Alyssa Rosenzweig <alyssa@rosenzweig.io> Reviewed-by: Adam Jackson <ajax@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/23451>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 0 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 529669f9a78..728fa74626e 100644
--- a/meson.build
+++ b/meson.build
@@ -1870,17 +1870,10 @@ endif
dep_selinux = null_dep
if get_option('selinux')
- if get_option('execmem') != true
- warning('execmem option is disabled, selinux will not be able to use execmem.')
- endif
dep_selinux = dependency('libselinux')
pre_args += '-DMESA_SELINUX'
endif
-if get_option('execmem')
- pre_args += '-DMESA_EXECMEM'
-endif
-
_libunwind = get_option('libunwind') \
.require(not with_platform_android, error_message : 'Android requires the use of the backtrace library, not libunwind')
if host_machine.system() == 'darwin'