summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-07-01 10:04:03 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-07-23 15:34:23 -0700
commit7cf50af6f512024331d766832e0cc20a6a4499d7 (patch)
tree628458f7434b520aa5f02fff13b984a54577c9c4 /meson.build
parent3d6cffffcf41349ff5db332a4662adb49d842a3a (diff)
downloadmesa-7cf50af6f512024331d766832e0cc20a6a4499d7.tar.gz
mesa-7cf50af6f512024331d766832e0cc20a6a4499d7.tar.bz2
mesa-7cf50af6f512024331d766832e0cc20a6a4499d7.zip
meson: allow building all glx without any drivers
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=111016 Fixes: a47c525f3281a2753180e076c7e9b7772aff8f06 ("meson: build glx") Acked-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 13b561f99de..804b921b1a5 100644
--- a/meson.build
+++ b/meson.build
@@ -315,7 +315,7 @@ if with_glx == 'dri'
endif
endif
-if not (with_dri or with_gallium or with_glx == 'xlib' or with_glx == 'gallium-xlib')
+if not (with_dri or with_gallium or with_glx != 'disabled')
with_gles1 = false
with_gles2 = false
with_opengl = false
@@ -382,9 +382,7 @@ if with_glx != 'disabled'
error('xlib conflicts with any dri driver')
endif
elif with_glx == 'dri'
- if not with_dri
- error('dri based GLX requires at least one DRI driver')
- elif not with_shared_glapi
+ if not with_shared_glapi
error('dri based GLX requires shared-glapi')
endif
endif