summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2022-01-03 15:17:20 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2022-01-03 15:17:20 +0900
commit71f9400b2a4d1b1306c142944b969856435fd4a3 (patch)
treefb27c2d5eaa5baf9b5e460f05d0017c7dfe9eb78 /configure.ac
parent5f4c4c32b3adb8e8db444c38833efba00f5b9f83 (diff)
downloadman-db-71f9400b2a4d1b1306c142944b969856435fd4a3.tar.gz
man-db-71f9400b2a4d1b1306c142944b969856435fd4a3.tar.bz2
man-db-71f9400b2a4d1b1306c142944b969856435fd4a3.zip
Imported Upstream version 2.9.2upstream/2.9.2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 65dbedd..3c39a60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
m4_pattern_forbid([^MAN_])
# Initialise and check we're in the correct directory.
-AC_INIT([man-db], [2.9.1], [cjwatson@debian.org])
+AC_INIT([man-db], [2.9.2], [cjwatson@debian.org])
AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE([1.11 -Wall -Wno-override -Werror foreign dist-xz no-dist-gzip parallel-tests])
AM_MAINTAINER_MODE
@@ -16,7 +16,7 @@ AC_CONFIG_HEADER([config.h])
AC_CANONICAL_HOST
# Define below date and version information to be put into man pages etc.
-date=2020-02-25
+date=2020-06-01
AC_SUBST([date])dnl
roff_version=`echo AC_PACKAGE_VERSION | sed 's/-/\\-/g'`
AC_SUBST([roff_version])dnl
@@ -327,7 +327,12 @@ if test -n "$lzip"
then
unlzip="$lzip -dc"
fi
-if test -n "$gzip" || test -n "$compress" || test -n "$bzip2" || test -n "$xz" || test -n "$lzip" || test -n "$lzma"
+MAN_CHECK_PROGS([zstd], [ZSTD], [use ZSTD as zstd compression utility], [zstd])
+if test -n "$zstd"
+then
+ unzstd="$zstd -dc"
+fi
+if test -n "$compressor"
then
AC_DEFINE([COMP_CAT], [1], [Define if you have compressors and want to support compressed cat files.])
fi
@@ -339,6 +344,7 @@ AC_SUBST([bunzip2])
AC_SUBST([unlzma])
AC_SUBST([unxz])
AC_SUBST([unlzip])
+AC_SUBST([unzstd])
MAN_COMPRESS_LIB([z], [gzopen])
dnl To add more decompressors just follow the scheme above.