summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-05 11:16:30 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-05 11:16:30 -0800
commit9789b4dba120180760ec948089fc98ebab6eb28b (patch)
tree26ae9736985be2ef61032e7808b9fb0e2155c71f /doc/Makefile.am
downloadmake-9789b4dba120180760ec948089fc98ebab6eb28b.tar.gz
make-9789b4dba120180760ec948089fc98ebab6eb28b.tar.bz2
make-9789b4dba120180760ec948089fc98ebab6eb28b.zip
Imported Upstream version 3.82upstream/3.82
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..67eec3a
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,36 @@
+# -*-Makefile-*-, or close enough
+# Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009,
+# 2010 Free Software Foundation, Inc.
+# This file is part of GNU Make.
+#
+# GNU Make is free software; you can redistribute it and/or modify it under
+# the terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 3 of the License, or (at your option) any later
+# version.
+#
+# GNU Make is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
+# details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program. If not, see <http://www.gnu.org/licenses/>.
+
+TEXI2HTML = texi2html
+TEXI2HTML_FLAGS = -split_chapter
+
+info_TEXINFOS = make.texi
+make_TEXINFOS = fdl.texi make-stds.texi
+
+CLEANFILES = make*.html
+
+## ----------------------------- ##
+## Other documentation formats. ##
+## ----------------------------- ##
+
+html: make_1.html
+
+make_1.html: $(info_TEXINFOS) $(make_TEXINFOS)
+ $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/make.texi
+
+.PHONY: html