summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2018-06-12 17:34:54 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2018-06-12 17:35:01 +0900
commit46a0aa70a35939815807200bf1fa20c40eb70a8f (patch)
treefb9e6c918b2d0ab3935e96ec36bc4cc6f578cac5 /configure.ac
parenta97fbf725aa75db53756b59df6888e59b47c931d (diff)
parentcf55f4b64fc18401baba427c6d5ea4cb7b1ed094 (diff)
downloadlzo-accepted/tizen_5.0_unified.tar.gz
lzo-accepted/tizen_5.0_unified.tar.bz2
lzo-accepted/tizen_5.0_unified.zip
Merge branch 'tizen_base' into tizentizen_9.0_m2_releasetizen_8.0_m2_releasetizen_7.0_m2_releasetizen_6.5.m2_releasetizen_6.0.m2_releasetizen_5.5.m2_releasesubmit/tizen_6.5/20211028.163501submit/tizen_6.0_hotfix/20201103.115103submit/tizen_6.0_hotfix/20201102.192903submit/tizen_6.0/20201029.205503submit/tizen_5.5_wearable_hotfix/20201026.184307submit/tizen_5.5_mobile_hotfix/20201026.185107submit/tizen_5.5/20191031.000007submit/tizen_5.0/20181101.000007submit/tizen/20180615.072409submit/tizen/20180612.085133submit/tizen/20180612.084651accepted/tizen/unified/20180618.151445accepted/tizen/9.0/unified/20241030.232558accepted/tizen/8.0/unified/20231005.095211accepted/tizen/7.0/unified/hotfix/20221116.111123accepted/tizen/7.0/unified/20221110.060805accepted/tizen/6.5/unified/20211029.014748accepted/tizen/6.0/unified/hotfix/20201102.231413accepted/tizen/6.0/unified/20201030.112922accepted/tizen/5.5/unified/wearable/hotfix/20201027.101023accepted/tizen/5.5/unified/mobile/hotfix/20201027.074655accepted/tizen/5.5/unified/20191031.012511accepted/tizen/5.0/unified/20181102.031024tizen_9.0tizen_7.0_hotfixtizen_7.0tizen_6.5tizen_6.0_hotfixtizen_6.0tizen_5.5_wearable_hotfixtizen_5.5_tvtizen_5.5_mobile_hotfixtizen_5.5tizen_5.0accepted/tizen_unifiedaccepted/tizen_9.0_unifiedaccepted/tizen_8.0_unifiedaccepted/tizen_7.0_unified_hotfixaccepted/tizen_7.0_unifiedaccepted/tizen_6.5_unifiedaccepted/tizen_6.0_unified_hotfixaccepted/tizen_6.0_unifiedaccepted/tizen_5.5_unified_wearable_hotfixaccepted/tizen_5.5_unified_mobile_hotfixaccepted/tizen_5.5_unifiedaccepted/tizen_5.0_unified
Change-Id: I005b25a1dcc898cbdf59ac1559529584eed017af Signed-off-by: DongHun Kwak <dh0128.kwak@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 17 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 5c3963c..9c6f5e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@
#
# This file is part of the LZO data compression library.
#
-# Copyright (C) 1996-2014 Markus Franz Xaver Johannes Oberhumer
+# Copyright (C) 1996-2017 Markus Franz Xaver Johannes Oberhumer
# All Rights Reserved.
#
# The LZO library is free software; you can redistribute it and/or
@@ -31,13 +31,13 @@
# // Init
# ************************************************************************/
-AC_COPYRIGHT([Copyright (C) 1996-2014 Markus Franz Xaver Johannes Oberhumer.
+AC_COPYRIGHT([Copyright (C) 1996-2017 Markus Franz Xaver Johannes Oberhumer.
All Rights Reserved.
This configure script may be copied, distributed and modified under the
terms of the GNU General Public License; see COPYING for more details.])
AC_PREREQ(2.69)
-AC_INIT([LZO],[2.08],[markus@oberhumer.com],[lzo],[http://www.oberhumer.com/opensource/lzo/])
+AC_INIT([LZO],[2.10],[markus@oberhumer.com],[lzo],[http://www.oberhumer.com/opensource/lzo/])
AC_MSG_NOTICE([Configuring LZO $PACKAGE_VERSION])
AC_CONFIG_SRCDIR(src/lzo_init.c)
AC_CONFIG_AUX_DIR(autoconf)
@@ -60,6 +60,7 @@ fi
AC_PROG_CC
AM_PROG_CC_C_O
+AM_PROG_AR
AM_PROG_AS
AC_PROG_CPP
mfx_PROG_CPPFLAGS
@@ -67,13 +68,17 @@ AC_C_CONST
mfx_LZO_CHECK_ENDIAN
AC_SYS_LARGEFILE
-AM_INIT_AUTOMAKE([1.14.1 gnu subdir-objects])
+AM_INIT_AUTOMAKE([1.15 gnu subdir-objects -Wall -Werror])
AM_SILENT_RULES([yes])
AC_CONFIG_HEADERS([config.h:config.hin])
+AH_TOP([#ifndef __LZO_AUTOCONF_CONFIG_H_INCLUDED
+#define __LZO_AUTOCONF_CONFIG_H_INCLUDED 1])
+AH_BOTTOM([#endif /* already included */])
AC_ENABLE_STATIC
AC_DISABLE_SHARED
LT_INIT
+PKG_INSTALLDIR
# /***********************************************************************
@@ -164,7 +169,7 @@ AM_CONDITIONAL(LZO_USE_ASM_i386_obj_elf32, [false])
# // Write output files
# ************************************************************************/
-mfx_LZO_LZOCHK(["-I$srcdir"],[#include "include/lzo/lzoconf.h"],["src/lzo_supp.h"])
+mfx_LZO_LZOCHK(["-I$srcdir/include -I$srcdir"],[#include <lzo/lzoconf.h>],[<src/lzo_supp.h>])
if test -r .Conf.settings2; then
. ./.Conf.settings2
@@ -180,7 +185,7 @@ AC_CONFIG_COMMANDS_PRE([
test "X$DEFS" != "X" && DEFS="$DEFS "
DEFS="${DEFS}${my_DEFS}"
])
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile lzo2.pc])
AC_OUTPUT
@@ -203,7 +208,7 @@ cat <<EOF
LZO ${PACKAGE_VERSION} configured.
- Copyright (C) 1996-2014 Markus Franz Xaver Johannes Oberhumer
+ Copyright (C) 1996-2017 Markus Franz Xaver Johannes Oberhumer
All Rights Reserved.
The LZO library is free software; you can redistribute it and/or
@@ -221,9 +226,11 @@ cat <<EOF
http://www.oberhumer.com/opensource/lzo/
-Type \`make' to build LZO. Type \`make install' to install LZO.
-After installing LZO, please read the accompanied documentation.
+Type 'make' to build LZO.
+Type 'make check' and 'make test' to test LZO.
+Type 'make install' to install LZO.
+After installing LZO, please have a look at 'examples/simple.c'.
EOF
-# vi:ts=4:et
+# vim:set ts=4 sw=4 et: