summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2018-06-12 17:34:54 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2018-06-12 17:35:01 +0900
commit46a0aa70a35939815807200bf1fa20c40eb70a8f (patch)
treefb9e6c918b2d0ab3935e96ec36bc4cc6f578cac5 /Makefile.am
parenta97fbf725aa75db53756b59df6888e59b47c931d (diff)
parentcf55f4b64fc18401baba427c6d5ea4cb7b1ed094 (diff)
downloadlzo-46a0aa70a35939815807200bf1fa20c40eb70a8f.tar.gz
lzo-46a0aa70a35939815807200bf1fa20c40eb70a8f.tar.bz2
lzo-46a0aa70a35939815807200bf1fa20c40eb70a8f.zip
Merge branch 'tizen_base' into tizentizen_9.0_m2_releasetizen_8.0_m2_releasetizen_7.0_m2_releasetizen_6.5.m2_releasetizen_6.0.m2_releasetizen_5.5.m2_releasesubmit/tizen_6.5/20211028.163501submit/tizen_6.0_hotfix/20201103.115103submit/tizen_6.0_hotfix/20201102.192903submit/tizen_6.0/20201029.205503submit/tizen_5.5_wearable_hotfix/20201026.184307submit/tizen_5.5_mobile_hotfix/20201026.185107submit/tizen_5.5/20191031.000007submit/tizen_5.0/20181101.000007submit/tizen/20180615.072409submit/tizen/20180612.085133submit/tizen/20180612.084651accepted/tizen/unified/20180618.151445accepted/tizen/9.0/unified/20241030.232558accepted/tizen/8.0/unified/20231005.095211accepted/tizen/7.0/unified/hotfix/20221116.111123accepted/tizen/7.0/unified/20221110.060805accepted/tizen/6.5/unified/20211029.014748accepted/tizen/6.0/unified/hotfix/20201102.231413accepted/tizen/6.0/unified/20201030.112922accepted/tizen/5.5/unified/wearable/hotfix/20201027.101023accepted/tizen/5.5/unified/mobile/hotfix/20201027.074655accepted/tizen/5.5/unified/20191031.012511accepted/tizen/5.0/unified/20181102.031024tizen_9.0tizen_7.0_hotfixtizen_7.0tizen_6.5tizen_6.0_hotfixtizen_6.0tizen_5.5_wearable_hotfixtizen_5.5_tvtizen_5.5_mobile_hotfixtizen_5.5tizen_5.0accepted/tizen_unifiedaccepted/tizen_9.0_unifiedaccepted/tizen_8.0_unifiedaccepted/tizen_7.0_unified_hotfixaccepted/tizen_7.0_unifiedaccepted/tizen_6.5_unifiedaccepted/tizen_6.0_unified_hotfixaccepted/tizen_6.0_unifiedaccepted/tizen_5.5_unified_wearable_hotfixaccepted/tizen_5.5_unified_mobile_hotfixaccepted/tizen_5.5_unifiedaccepted/tizen_5.0_unified
Change-Id: I005b25a1dcc898cbdf59ac1559529584eed017af Signed-off-by: DongHun Kwak <dh0128.kwak@samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 19 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index beb0d71..e4d383b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,8 +3,9 @@
# Makefile --- Makefile for building the LZO library
#
# This file is part of the LZO data compression library.
+# http://www.oberhumer.com/opensource/lzo/
#
-# Copyright (C) 1996-2014 Markus Franz Xaver Johannes Oberhumer
+# Copyright (C) 1996-2017 Markus Franz Xaver Johannes Oberhumer
# All Rights Reserved.
#
@@ -13,6 +14,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)
LDADD = src/liblzo2.la
lib_LTLIBRARIES =
noinst_PROGRAMS =
+pkgconfig_DATA = lzo2.pc
##/***********************************************************************
@@ -20,37 +22,37 @@ noinst_PROGRAMS =
##************************************************************************/
doc_DATA = AUTHORS COPYING NEWS THANKS doc/LZO.FAQ doc/LZO.TXT doc/LZOAPI.TXT
-EXTRA_DIST += BUGS CMakeLists.txt autoconf/shtool
+EXTRA_DIST += BUGS CMakeLists.txt lzo2.pc.cmakein autoconf/shtool
# hooks for Automake targets
dist-hook: dist-hook-1
dist-hook-1:
- cp -pR $(srcdir)/B/ $(srcdir)/asm/ $(srcdir)/doc/ $(srcdir)/util/ "$(distdir)/"
+ cp -pR '$(srcdir)/B/' '$(srcdir)/asm/' '$(srcdir)/doc/' '$(srcdir)/util/' '$(distdir)/'
-rm -f $(distdir)/util/*.dat
check-local: all-am
- ./lzotest/lzotest -mlzo -n2 -q $(top_srcdir)/COPYING
+ ./lzotest/lzotest$(EXEEXT) -mlzo -n2 -q '$(top_srcdir)/COPYING'
@echo
- @echo "All checks passed."
+ @echo "===== All checks passed. Type 'make test' for more exhaustive testing. ====="
@echo
# special targets
basic-test: all
- ./lzotest/lzotest -mlzo -n2 -q $(top_srcdir)/COPYING
- ./tests/align
- ./tests/chksum
- ./examples/simple
- ./minilzo/testmini
+ ./lzotest/lzotest$(EXEEXT) -mlzo -n2 -q '$(top_srcdir)/COPYING'
+ ./tests/align$(EXEEXT)
+ ./tests/chksum$(EXEEXT)
+ ./examples/simple$(EXEEXT)
+ ./minilzo/testmini$(EXEEXT)
test: all
- ./lzotest/lzotest -mavail -n10 -q $(top_srcdir)/COPYING
- $(SHELL) -e $(top_srcdir)/util/check.sh $(top_srcdir)
- ./tests/align
- ./tests/chksum
- ./examples/simple
- ./minilzo/testmini
+ ./lzotest/lzotest$(EXEEXT) -mavail -n10 -q '$(top_srcdir)/COPYING'
+ LZOTEST=./lzotest/lzotest$(EXEEXT) $(SHELL) '$(top_srcdir)/util/check.sh' '$(top_srcdir)'
+ ./tests/align$(EXEEXT)
+ ./tests/chksum$(EXEEXT)
+ ./examples/simple$(EXEEXT)
+ ./minilzo/testmini$(EXEEXT)
@echo
- @echo "All tests passed. Now you are ready to install LZO."
+ @echo "===== All tests passed. Now you are ready to install LZO. ====="
@echo