summaryrefslogtreecommitdiff
path: root/packaging/libzypp-bindings.spec
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2013-05-27 15:37:23 -0400
committerDongHun Kwak <dh0128.kwak@samsung.com>2017-01-10 17:39:23 +0900
commit85317f64974e9448e62a0bd26637e06195473252 (patch)
tree5100d656a2d1e69fdf342af72c24ed0bd875eebc /packaging/libzypp-bindings.spec
parentbb3882662b5f428d70fa009f938ee62c6319633c (diff)
downloadlibzypp-bindings-85317f64974e9448e62a0bd26637e06195473252.tar.gz
libzypp-bindings-85317f64974e9448e62a0bd26637e06195473252.tar.bz2
libzypp-bindings-85317f64974e9448e62a0bd26637e06195473252.zip
Rebase for libzypp-bindings 0.7.3
Change-Id: I8a296480009b197cbdfe235d8232f02b7e9bbeef Signed-off-by: DongHun Kwak <dh0128.kwak@samsung.com>
Diffstat (limited to 'packaging/libzypp-bindings.spec')
-rw-r--r--packaging/libzypp-bindings.spec64
1 files changed, 64 insertions, 0 deletions
diff --git a/packaging/libzypp-bindings.spec b/packaging/libzypp-bindings.spec
new file mode 100644
index 0000000..305b869
--- /dev/null
+++ b/packaging/libzypp-bindings.spec
@@ -0,0 +1,64 @@
+#
+# spec file for package libzypp-bindings
+#
+# Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+Name: libzypp-bindings
+Version: 0.6.1
+Release: 0
+License: GPL-2.0+
+Summary: Bindings for libzypp
+Group: Development/Sources
+Source: %{name}-%{version}.tar.gz
+Source1001: libzypp-bindings.manifest
+
+BuildRequires: cmake gcc-c++ python-devel
+BuildRequires: swig
+
+BuildRequires: libzypp-devel
+
+%description
+This package provides bindings for libzypp, the library for package management.
+
+%prep
+%setup -q
+cp %{SOURCE1001} .
+
+%build
+mkdir build
+cd build
+%cmake -DCMAKE_INSTALL_PREFIX=%{prefix} \
+ -DPYTHON_SITEDIR=%{python_sitearch} \
+ -DLIB=%{_lib} \
+ -DCMAKE_VERBOSE_MAKEFILE=TRUE \
+ -DCMAKE_C_FLAGS_RELEASE:STRING="%{optflags}" \
+ -DCMAKE_CXX_FLAGS_RELEASE:STRING="%{optflags}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=1 \
+ ..
+make -j1
+
+%install
+cd build
+make install DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+
+%package -n python-zypp
+Summary: Python bindings for libzypp
+Group: Development/Languages/Python
+Requires: libzypp
+
+%description -n python-zypp
+Python bindings of libzypp
+
+
+%files -n python-zypp
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%{python_sitearch}/_zypp.so
+%{python_sitearch}/zypp.py*