summaryrefslogtreecommitdiff
path: root/packaging/libzio.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/libzio.spec')
-rw-r--r--packaging/libzio.spec91
1 files changed, 91 insertions, 0 deletions
diff --git a/packaging/libzio.spec b/packaging/libzio.spec
new file mode 100644
index 0000000..7517696
--- /dev/null
+++ b/packaging/libzio.spec
@@ -0,0 +1,91 @@
+
+%if "%{run_tests}" == "1"
+ %define check %%check
+%endif
+
+
+Name: libzio
+Version: 1.04
+Release: 0
+License: GPL-2.0+
+Summary: A Library for Accessing Compressed Text Files
+Group: System/Libraries
+Source: %{name}-%{version}.tar.bz2
+Source2: baselibs.conf
+Source1001: libzio.manifest
+BuildRequires: bzip2-devel
+BuildRequires: xz
+BuildRequires: xz-devel
+BuildRequires: zlib-devel
+
+%description
+Libzio provides a wrapper function for reading or writing gzip or bzip2
+files with FILE streams.
+
+%package devel
+Summary: Libzio development files
+Group: Development/Libraries/C and C++
+Requires: libzio = %{version}
+
+%description devel
+Libzio development files including zio.h, the manual page fzopen(3),
+and static library.
+
+%prep
+%setup -q
+cp %{SOURCE1001} .
+
+%build
+make %{?_smp_mflags} noweak
+
+%check
+make testt
+make tests
+
+export TEST_LOG="/tmp/%{name}_test"
+rm -f $TEST_LOG
+chmod 755 ./run_test.sh
+for comp in gzip bzip2 lzma xz
+do
+ $comp -c < fzopen.3.in > fzopen.test
+ ./testt fzopen.test | cmp fzopen.3.in -
+ if [ $? == 0 ]
+ then
+ echo "TEST: PASS: $comp uncompress test" >> $TEST_LOG
+ else
+ echo "TEST: FAIL: $comp uncompress test" >> $TEST_LOG
+ fi
+ cat fzopen.test | ./tests ${comp:0:1} | cmp fzopen.3.in -
+ if [ $? == 0 ]
+ then
+ echo "TEST: PASS: $comp uncompress test" >> $TEST_LOG
+ else
+ echo "TEST: FAIL: $comp uncompress test" >> $TEST_LOG
+ fi
+done
+./run_test.sh %{name} %{version}
+
+%install
+make DESTDIR=%{buildroot} install libdir=%{_libdir} mandir=%{_mandir}
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%files
+%manifest %{name}.manifest
+%defattr(-,root,root)
+%license COPYING
+%{_libdir}/libzio.so.1
+%{_libdir}/libzio.so.%{version}
+
+%files devel
+%manifest %{name}.manifest
+%defattr(-,root,root)
+%license COPYING
+%{_libdir}/libzio.a
+%{_libdir}/libzio.so
+%{_mandir}/man3/fzopen.3*
+/usr/include/zio.h
+
+%changelog