summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a225ab7..36097f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,13 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
#set(CMAKE_VERBOSE_MAKEFILE ON)
#comment or remove the above line before release
+if ("${ARCH}" MATCHES "aarch64")
+MESSAGE(${ARCH})
+set(LIB_SUFFIX "64")
+else ("${ARCH}" MATCHES "aarch64")
+MESSAGE(${ARCH})
+endif ("${ARCH}" MATCHES "aarch64")
+
add_definitions (-DZINT_VERSION=\"${ZINT_VERSION}\" -Wno-unused-variable -Wall )
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )