summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTae-Young Chung <ty83.chung@samsung.com>2015-08-02 14:51:58 +0900
committerTae-Young Chung <ty83.chung@samsung.com>2015-08-02 14:52:41 +0900
commit6b95e4f11a5ac5c9fbc89f9d0982787ddc24f929 (patch)
tree7f9464bdc97f155bd7910d9c21c6221feaf95354 /CMakeLists.txt
parentb58273ff2547cde2ab6edcf2fca0530726f3efcc (diff)
downloadlibzint-6b95e4f11a5ac5c9fbc89f9d0982787ddc24f929.tar.gz
libzint-6b95e4f11a5ac5c9fbc89f9d0982787ddc24f929.tar.bz2
libzint-6b95e4f11a5ac5c9fbc89f9d0982787ddc24f929.zip
Add Zint Barcode Generator
Change-Id: I5fe674ec5ee8ba7249edd988822990974e01da06 Signed-off-by: Tae-Young Chung <ty83.chung@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..a225ab7
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,44 @@
+# (c) 2008 by BogDan Vatra < bogdan@licentia.eu >
+
+cmake_minimum_required(VERSION 2.6)
+project(zint-package)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+#set(CMAKE_VERBOSE_MAKEFILE ON)
+#comment or remove the above line before release
+
+add_definitions (-DZINT_VERSION=\"${ZINT_VERSION}\" -Wno-unused-variable -Wall )
+
+set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+
+include (SetPaths.cmake)
+
+INCLUDE (CheckCXXCompilerFlag)
+
+if (CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_GNUCC)
+ check_cxx_compiler_flag("-Wall" CXX_COMPILER_FLAG_WALL)
+ if (CXX_COMPILER_FLAG_WALL)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-unused-variable -Wall")
+ endif (CXX_COMPILER_FLAG_WALL)
+endif (CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_GNUCC)
+
+add_subdirectory(backend)
+
+CONFIGURE_FILE(
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
+ IMMEDIATE @ONLY)
+
+ADD_CUSTOM_TARGET(uninstall
+ "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
+
+install(FILES cmake/modules/FindZint.cmake DESTINATION /usr/share/cmake/Modules COMPONENT Devel)
+
+# This needs to be run very last so other parts of the scripts can take
+# advantage of this.
+IF(NOT ZINT_HAS_BEEN_RUN_BEFORE)
+ SET(ZINT_HAS_BEEN_RUN_BEFORE 1 CACHE INTERNAL "Flag to track whether this is the first time running CMake or if CMake has been configured before")
+ENDIF(NOT ZINT_HAS_BEEN_RUN_BEFORE)
+
+