summaryrefslogtreecommitdiff
path: root/tests/numbers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/numbers/Makefile.am')
-rw-r--r--tests/numbers/Makefile.am21
1 files changed, 0 insertions, 21 deletions
diff --git a/tests/numbers/Makefile.am b/tests/numbers/Makefile.am
deleted file mode 100644
index 8fa9ba0a..00000000
--- a/tests/numbers/Makefile.am
+++ /dev/null
@@ -1,21 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-$(top_builddir)/xsltproc/xsltproc:
- @(cd ../../xsltproc ; $(MAKE) xsltproc)
-
-EXTRA_DIST = format-number.xsl format-number.xml format-number.out
-
-CLEANFILES = .memdump
-
-valgrind:
- @echo '## Running the regression tests under Valgrind'
- $(MAKE) CHECKER='libtool --mode=execute valgrind -q --leak-check=full' tests
-
-test tests: $(top_builddir)/xsltproc/xsltproc
- @echo '## Running numbers tests'
- @(echo > .memdump)
- @($(CHECKER) $(top_builddir)/xsltproc/xsltproc $(srcdir)/format-number.xsl $(srcdir)/format-number.xml > format-number.res ; \
- diff $(srcdir)/format-number.out format-number.res ; \
- grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0" || true;\
- rm -f format-number.res)
-