summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am62
1 files changed, 46 insertions, 16 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5645bb01..cadc5cc9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,26 +1,56 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS=docs REC1 REC2 REC general namespaces keys numbers documents \
- extensions reports xmlspec multiple xinclude XSLTMark docbook \
- exslt plugins fuzz
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir)
-all:
+SUBDIRS = xmlspec multiple xinclude XSLTMark docbook fuzz
+
+DEPENDENCIES = $(top_builddir)/libxslt/libxslt.la \
+ $(top_builddir)/libexslt/libexslt.la
+
+LDADD = $(top_builddir)/libxslt/libxslt.la \
+ $(top_builddir)/libexslt/libexslt.la \
+ $(LIBXML_LIBS)
+
+check_PROGRAMS = runtest
+
+runtest_SOURCES = runtest.c
+
+if WITH_MODULES
-# Each subdirectory has it's own Makefile to cater for the unique
-# requirements of that subdirectory. In general, xsltproc will be
-# run on the *.xsl / *.xml file combinations, and the output of that
-# run will be compared with the "expected" output contained in *.out
-# and (if errors are expected) in *.err
-test tests:
- @(cur=`pwd` ; for dir in $(SUBDIRS) ; do cd $$dir ; $(MAKE) CHECKER='$(CHECKER)' tests ; cd $$cur ; done)
+check_LTLIBRARIES = xmlsoft_org_xslt_testplugin.la
-valgrind:
- @echo '## Running the regression tests under Valgrind'
- @echo '## Go get a cup of coffee it is gonna take a while ...'
- $(MAKE) CHECKER='libtool --mode=execute valgrind -q --leak-check=full' tests
+# our rpath is a rather unorthodox location as we
+# don't want to pollute $(DESTDIR) with the test plugin
+
+plugindir = $(abs_builddir)/.libs
+
+xmlsoft_org_xslt_testplugin_la_CFLAGS = $(AM_CFLAGS) -DMODULE_COMPILE
+xmlsoft_org_xslt_testplugin_la_SOURCES = testplugin.c
+xmlsoft_org_xslt_testplugin_la_LIBADD = $(top_builddir)/libxslt/libxslt.la $(EXTRA_LIBS)
+xmlsoft_org_xslt_testplugin_la_LDFLAGS = \
+ $(AM_LDFLAGS) -no-undefined \
+ -module -avoid-version -rpath $(plugindir)
+
+endif
+
+all:
-full: tests docbook_tests
+check-local:
+ cd $(srcdir) && LIBXSLT_PLUGINS_PATH=$(plugindir) $(abs_builddir)/runtest
docbook_tests:
@(cd docbook ; $(MAKE) full)
+dist-hook:
+ cp -a $(srcdir)/REC $(distdir)
+ cp -a $(srcdir)/REC2 $(distdir)
+ cp -a $(srcdir)/documents $(distdir)
+ cp -a $(srcdir)/encoding $(distdir)
+ cp -a $(srcdir)/exslt $(distdir)
+ cp -a $(srcdir)/extensions $(distdir)
+ cp -a $(srcdir)/general $(distdir)
+ cp -a $(srcdir)/keys $(distdir)
+ cp -a $(srcdir)/namespaces $(distdir)
+ cp -a $(srcdir)/numbers $(distdir)
+ cp -a $(srcdir)/plugins $(distdir)
+ cp -a $(srcdir)/reports $(distdir)