summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8304ebb2..cefe0374 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,20 @@
+## don't bother compiling the breakpoint library unless it is needed
+if WITH_DEBUGGER
+SUBDIRS = \
+ breakpoint \
+ libxslt \
+ libexslt \
+ xsltproc \
+ tests \
+ doc
+else
SUBDIRS = \
libxslt \
- breakpoint \
libexslt \
xsltproc \
tests \
doc
+endif
confexecdir=$(libdir)
confexec_DATA = xsltConf.sh