summaryrefslogtreecommitdiff
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2002-02-06 10:35:19 +0000
committerDaniel Veillard <veillard@src.gnome.org>2002-02-06 10:35:19 +0000
commitac6924c939da9b0655f372f168c39cc657e01423 (patch)
tree6445cde903fd7a7805ebdd78acd29da63dbbc118 /python/Makefile.am
parentf0cb070b695309bc9c33442b66165e1c5db7f883 (diff)
downloadlibxslt-ac6924c939da9b0655f372f168c39cc657e01423.tar.gz
libxslt-ac6924c939da9b0655f372f168c39cc657e01423.tar.bz2
libxslt-ac6924c939da9b0655f372f168c39cc657e01423.zip
refactored make tests, make all now don't run the test suite added tests
* Makefile.am configure.in tests/Makefile.am tests/*/Makefile.am tests/*/*/Makefile.am: refactored make tests, make all now don't run the test suite * python/Makefile.am: added tests * python/tests/basic.py python/tests/Makefile.am: added the first basic test, memory debug included Daniel
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 6d62d51d..3a4d4153 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -1,4 +1,4 @@
-# SUBDIRS= . tests
+SUBDIRS= . tests
LIBS=-L../libxslt/.libs -L../libxslt -lxslt -L../libexslt/.libs -L../libexslt -lexslt $(PYTHON_SITE_PACKAGES)/_libxml.so $(LIBXML_LIBS)
INCLUDES=-I/usr/include/python$(PYTHON_VERSION) -I$(PYTHON_INCLUDES) $(LIBXML_CFLAGS) -I$(top_srcdir)
@@ -61,7 +61,7 @@ GENERATED= $(srcdir)/libxsltclass.py \
$(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
cd $(srcdir) && $(PYTHON) $(GENERATE)
-tests: all
+tests test: all
cd tests && $(MAKE) tests
clean: