summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2003-04-27 10:47:55 +0000
committerDaniel Veillard <veillard@src.gnome.org>2003-04-27 10:47:55 +0000
commitbe5c2c746e6852f5b2375172811bc53fdcf4f0bf (patch)
tree9bab4e2e28e90d6930248993ae9ad77345d338fa /doc/Makefile.am
parent6eb57275e219841ff275e04eaee68a5ad7dfa3e4 (diff)
downloadlibxslt-be5c2c746e6852f5b2375172811bc53fdcf4f0bf.tar.gz
libxslt-be5c2c746e6852f5b2375172811bc53fdcf4f0bf.tar.bz2
libxslt-be5c2c746e6852f5b2375172811bc53fdcf4f0bf.zip
updated the web site, made the transition to XHTML1 added validity
* NEWS doc/*.xsl doc/*.html: updated the web site, made the transition to XHTML1 added validity checking to the makefile rules. Daniel
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 53932c45..75daf794 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -36,14 +36,16 @@ web: $(PAGES) $(APIPAGES)
$(PAGES): $(srcdir)/xslt.html $(srcdir)/site.xsl
-@(if [ -x $(bindir)/xsltproc ] ; then \
$(bindir)/xsltproc --html $(srcdir)/site.xsl $(srcdir)/xslt.html > index.html ; fi )
+ -@(if [ -x $(bindir)/xmllint ] ; then \
+ $(bindir)/xmllint --valid --noout $(PAGES) ; fi );
$(top_srcdir)/NEWS: $(top_srcdir)/doc/news.xsl $(top_srcdir)/doc/news.html
-@(if [ -x $(bindir)/xsltproc ] ; then \
- $(bindir)/xsltproc --html $(top_srcdir)/doc/news.xsl $(top_srcdir)/doc/news.html > $(top_srcdir)/NEWS ; fi );
+ $(bindir)/xsltproc $(top_srcdir)/doc/news.xsl $(top_srcdir)/doc/news.html > $(top_srcdir)/NEWS ; fi );
libxslt.xsa: $(top_srcdir)/doc/xsa.xsl $(top_srcdir)/doc/news.html
-@(if [ -x $(bindir)/xsltproc ] ; then \
- $(bindir)/xsltproc --html $(top_srcdir)/doc/xsa.xsl $(top_srcdir)/doc/news.html > libxslt.xsa ; fi );
+ $(bindir)/xsltproc $(top_srcdir)/doc/xsa.xsl $(top_srcdir)/doc/news.html > libxslt.xsa ; fi );
$(APIPAGES): libxslt-refs.xml site.xsl api.xsl
-@(if [ -x $(bindir)/xsltproc ] ; then \