summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2009-09-16 16:16:21 +0200
committerDaniel Veillard <veillard@redhat.com>2009-09-16 16:16:21 +0200
commit482e7b7e1215dd78e163a6f6bfc5b8b2a83c990c (patch)
tree9ec900eea62e570abf6ae3151050985a064b7c91 /doc/Makefile.am
parent8619ab630e705805cafa4ba24c94b6c1311d0e01 (diff)
downloadlibxslt-482e7b7e1215dd78e163a6f6bfc5b8b2a83c990c.tar.gz
libxslt-482e7b7e1215dd78e163a6f6bfc5b8b2a83c990c.tar.bz2
libxslt-482e7b7e1215dd78e163a6f6bfc5b8b2a83c990c.zip
Add API versioning and various cleanups
* doc/symbols.xml doc/syms.xsl doc/checkapisym.xsl libxslt/libxslt.syms: the new symbol files, checking and stylesheets, based on libxml2 ones * configure.in doc/Makefile.am libxslt/Makefile.am: modifications needed to activate the symbol versioning * doc/libxslt-api.xml doc/libxslt-refs.xml doc/EXSLT/libexslt-api.xml doc/EXSLT/libexslt-refs.xml: regenerated * libexslt/crypto.c libxslt/Makefile.am libxslt/keys.c libxslt/variables.c libxslt/xslt.c libxslt/xsltInternals.h libxslt/xsltlocale.c libxslt/xsltlocale.h: various cleanups
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 515dfba1..d8aaf2b1 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -32,6 +32,9 @@ EXTRA_DIST = \
EXSLT/libexslt-refs.xml \
libxslt-api.xml \
libxslt-refs.xml \
+ symbols.xml \
+ checkapisym.xsl \
+ syms.xsl \
libxslt.xsa \
newapi.xsl \
news.xsl \
@@ -137,10 +140,12 @@ EXSLT/html/index.html: EXSLT/libexslt-api.xml \
libxslt-api.xml libxslt-refs.xml EXSLT/libexslt-api.xml \
- EXSLT/libexslt-refs.xml: $(srcdir)/apibuild.py $(top_srcdir)/libxslt/*.h \
+ EXSLT/libexslt-refs.xml ../libxslt/libxslt.syms : $(srcdir)/apibuild.py $(top_srcdir)/libxslt/*.h \
$(top_srcdir)/libxslt/*.c $(top_srcdir)/libexslt/*.h \
$(top_srcdir)/libexslt/*.c
-($(srcdir)/apibuild.py)
+ ($(XSLTPROC) checkapisym.xsl libxslt-api.xml)
+ ($(XSLTPROC) -o ../libxslt/libxslt.syms syms.xsl symbols.xml)
xsltproc.1: xsltproc.xml
-@(xsltproc --nonet xsltproc.xml)