summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoumen Petrov <bugtrack@roumenpetrov.info>2012-05-27 16:53:51 +0300
committerDaniel Veillard <veillard@redhat.com>2012-08-16 16:33:32 +0800
commitc5eda69c278119e7a66aa5371cd3521cead79fa1 (patch)
tree24bd92e78c5c962199c15b54240acae237c37feb /configure.in
parentfaeaa3146cab124628785c4b536ba0b824292f8d (diff)
downloadlibxslt-c5eda69c278119e7a66aa5371cd3521cead79fa1.tar.gz
libxslt-c5eda69c278119e7a66aa5371cd3521cead79fa1.tar.bz2
libxslt-c5eda69c278119e7a66aa5371cd3521cead79fa1.zip
use only native crypto-API for mingw* hosts
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3cf2ba56..e5e7c812 100644
--- a/configure.in
+++ b/configure.in
@@ -380,6 +380,14 @@ if test "$with_crypto" = "no" ; then
LIBGCRYPT_CFLAGS=""
LIBGCRYPT_LIBS=""
else
+case $host in
+ *-mingw*)
+ dnl Use only native crypto-API for mingw* hosts
+ dnl TODO: to implement --with-crypto=foo to allow switch between
+ dnl crypto libraries
+ WITH_CRYPTO=1
+ ;;
+ *)
AC_PATH_PROG(LIBGCRYPT_CONFIG, libgcrypt-config, no)
if test "$LIBGCRYPT_CONFIG" != "no" ; then
LIBGCRYPT_VERSION=`$LIBGCRYPT_CONFIG --version`
@@ -400,6 +408,7 @@ else
LIBGCRYPT_LIBS=""
echo 'Crypto extensions will not be available. Install libgcrypt and reconfigure to make available.'
fi
+esac
fi
AC_SUBST(WITH_CRYPTO)
AC_SUBST(LIBGCRYPT_CFLAGS)