summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2007-01-03 15:39:01 +0000
committerDaniel Veillard <veillard@src.gnome.org>2007-01-03 15:39:01 +0000
commit7581a7896fbf2d9216622b54265ed202692ea006 (patch)
tree8311919f754e90d01cda8e7c56bd5c4b404378c5 /configure.in
parentc2d91bc1cb0be65587df6302ee3989fc5ee97700 (diff)
downloadlibxslt-7581a7896fbf2d9216622b54265ed202692ea006.tar.gz
libxslt-7581a7896fbf2d9216622b54265ed202692ea006.tar.bz2
libxslt-7581a7896fbf2d9216622b54265ed202692ea006.zip
adapt the extra versioning code to SVN Daniel
* configure.in: adapt the extra versioning code to SVN Daniel svn path=/trunk/; revision=1412
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bf93c3a3..0efadd48 100644
--- a/configure.in
+++ b/configure.in
@@ -31,6 +31,14 @@ if test -f CVS/Entries; then
then
LIBXSLT_VERSION_EXTRA="-CVS$extra"
fi
+else if test -d .svn ; then
+ extra=`svn info | grep Revision | sed 's+Revision: ++'`
+ echo extra=$extra
+ if test "$extra" != ""
+ then
+ LIBXSLT_VERSION_EXTRA="-SVN$extra"
+ fi
+fi
fi
AC_SUBST(LIBXSLT_MAJOR_VERSION)