summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2009-08-14 08:58:50 +0200
committerDaniel Veillard <veillard@redhat.com>2009-08-14 08:58:50 +0200
commit52588cf2f11ce43a184cc3c54fbe50dea19930da (patch)
treedca951b8ac15bba3fd3609c9cd63153010e7fe09 /configure.in
parent9d0f428e4daa0fd880dc9cc8a9417adf41a3106a (diff)
downloadlibxslt-52588cf2f11ce43a184cc3c54fbe50dea19930da.tar.gz
libxslt-52588cf2f11ce43a184cc3c54fbe50dea19930da.tar.bz2
libxslt-52588cf2f11ce43a184cc3c54fbe50dea19930da.zip
Adding a test program to check thread reentrancy
* xsltproc/testThreads.c: based loosely on libxml2 one, checks concurrent use of the same stylesheet and extensions reentrancy * config.h.in configure.in: we need to check for pthreads * Makefile.am xsltproc/Makefile.am: add the new program and insert in make check
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 92edb867..60f189f4 100644
--- a/configure.in
+++ b/configure.in
@@ -119,6 +119,12 @@ AM_PROG_LIBTOOL
AC_CHECK_HEADERS(sys/types.h sys/time.h stdlib.h unistd.h string.h)
+dnl Look for pthread.h, needed for testThreads
+AC_CHECK_HEADER(pthread.h,
+ AC_CHECK_LIB(pthread, pthread_join,[
+ AC_DEFINE([HAVE_LIBPTHREAD], [], [Define if pthread library is there (-lpthread)])
+ AC_DEFINE([HAVE_PTHREAD_H], [], [Define if <pthread.h> is there]) ]))
+
dnl
dnl Detect supported locale
dnl