summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2003-08-18 22:41:26 +0000
committerDaniel Veillard <veillard@src.gnome.org>2003-08-18 22:41:26 +0000
commit1d9e27ecab804d55e399a28df5587244e1155246 (patch)
tree94d47ee168b912b83d3a6b7e3af960e93b50aa0b /configure.in
parent7f25aab1b425742825210606ce989c5d8c406e91 (diff)
downloadlibxslt-1d9e27ecab804d55e399a28df5587244e1155246.tar.gz
libxslt-1d9e27ecab804d55e399a28df5587244e1155246.tar.bz2
libxslt-1d9e27ecab804d55e399a28df5587244e1155246.zip
applied patch from Mikhail Grushinskiy for compilation with MingW compiler
* xsltproc/Makefile.am libxslt/libxslt.h libxslt/numbersInternals.h libexslt/*.c configure.in: applied patch from Mikhail Grushinskiy for compilation with MingW compiler on Windows. Daniel
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2f383a37..aea19a9f 100644
--- a/configure.in
+++ b/configure.in
@@ -413,6 +413,21 @@ if test "${LOGNAME}" = "veillard" -a "`pwd`" = "/u/veillard/XSLT" ; then
# PYTHONSODV="libxsltmod.so.dv"
fi
+WIN32_EXTRA_LIBADD=
+WIN32_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-mingw*)
+ WIN32_EXTRA_LIBADD="-lwsock32"
+ WIN32_EXTRA_LDFLAGS="-no-undefined"
+ AC_DEFINE([_WINSOCKAPI_],1,[Using the Win32 Socket implementation])
+ AC_DEFINE([snprintf],[_snprintf],[Win32 Std C name mangling work-around])
+ AC_DEFINE([vsnprintf],[_vsnprintf],[Win32 Std C name mangling work-around])
+ ;;
+esac
+AC_SUBST(WIN32_EXTRA_LIBADD)
+AC_SUBST(WIN32_EXTRA_LDFLAGS)
+
+
AC_SUBST(XSLTPROCDV)
AC_SUBST(PYTHONSODV)
AC_SUBST(XML_CONFIG)