summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sf.net>2010-03-08 14:58:00 +0200
committerStefan Kost <ensonic@users.sf.net>2010-04-12 22:00:29 +0300
commit193322ac0519651d846eed2377f13d5b214fb108 (patch)
treecb091f001141861bf1cf97a5a1d8aa2269d0c13c /configure.in
parentdbd66b994d9e45948cbcc5e42f5d903993904f75 (diff)
downloadlibxslt-193322ac0519651d846eed2377f13d5b214fb108.tar.gz
libxslt-193322ac0519651d846eed2377f13d5b214fb108.tar.bz2
libxslt-193322ac0519651d846eed2377f13d5b214fb108.zip
profiling: add callgraph report
This patch also tracks who called a template and how often. Based on that the output of xsltproc --profile now also contains a gprof alike callgraph. If available posix monotonic clocks are the preferred way to get timestamps.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7fef7a2f..d4418d33 100644
--- a/configure.in
+++ b/configure.in
@@ -239,6 +239,8 @@ AC_CHECK_FUNC(floor, , AC_CHECK_LIB(m, floor,
AC_CHECK_FUNC(fabs, , AC_CHECK_LIB(m, fabs,
[M_LIBS="-lm"; AC_DEFINE(HAVE_FABS)]))
+
+
AC_CHECK_FUNCS(gettimeofday)
AC_CHECK_FUNCS(mktime localtime localtime_r asctime time gmtime_r ftime)
@@ -246,6 +248,14 @@ dnl Checking the standard string functions availability
AC_CHECK_FUNCS(printf sprintf fprintf snprintf vfprintf vsprintf vsnprintf sscanf,,
NEED_TRIO=1)
+dnl Checking for POSIX timers
+AC_CHECK_FUNCS(clock_gettime, [], [
+ AC_CHECK_LIB(rt, clock_gettime, [
+ AC_DEFINE(HAVE_CLOCK_GETTIME, 1)
+ EXTRA_LIBS="$EXTRA_LIBS -lrt"
+ ])
+])
+
dnl
dnl Check for trio string functions
dnl
@@ -458,7 +468,7 @@ dnl the ability to specify the location of the libxml
dnl library during linking and compilation.
dnl
dnl original work - Mathieu Lacage 30/03/2000
-dnl some tweaking - David Härdeman 30/10/2001
+dnl some tweaking - David Härdeman 30/10/2001
dnl
LIBXML_CONFIG_PREFIX=""