summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2002-03-19 18:52:17 +0000
committerDaniel Veillard <veillard@src.gnome.org>2002-03-19 18:52:17 +0000
commitf6f08bd890020ae91aeb00e9ac99d99460733ee2 (patch)
treedfd3b24967cd6af4b7768d4c501402a588eccaae /Makefile.am
parent073f51a7408de89931721bcfd5e382a1f0f09d39 (diff)
downloadlibxslt-f6f08bd890020ae91aeb00e9ac99d99460733ee2.tar.gz
libxslt-f6f08bd890020ae91aeb00e9ac99d99460733ee2.tar.bz2
libxslt-f6f08bd890020ae91aeb00e9ac99d99460733ee2.zip
added "make valgrind" targets to run the test suite under the debugger
* Makefile.am tests/Makefile.am tests/*/Makefile.am tests/*/*/Makefile.am : added "make valgrind" targets to run the test suite under the debugger control * transform.c: valgrind spotted 2 bugs, one related to the ordering of the deallocation of the data associated to a transofrmation, the second in xsltCopyTree when the new node may have been coalesced with an adjacent text node. The regression tests now pass cleanly under testgrind. Daniel
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 88e821b5..da9340ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,6 +53,11 @@ tests: dummy
@(cd tests ; $(MAKE) tests)
@(cd python ; $(MAKE) tests)
+valgrind:
+ @echo '## Running the regression tests under Valgrind'
+ @echo '## Go get a cup of coffee it is gonna take a while ...'
+ @(cd tests ; $(MAKE) CHECKER='valgrind -q' tests)
+
cleantar:
@(rm -f libxslt*.tar.gz)