summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRan Benita <ran234@gmail.com>2014-01-13 18:19:36 +0200
committerRan Benita <ran234@gmail.com>2014-01-13 18:24:24 +0200
commitddbefda383cccbf8d537b30471fc2ce893826d35 (patch)
treef6ad078ad23714cd9d26612ebe2cd0881a460a69 /Makefile.am
parenta9c56f643db9012bf2c91fcbc3bed5baf16ea848 (diff)
downloadlibxkbcommon-ddbefda383cccbf8d537b30471fc2ce893826d35.tar.gz
libxkbcommon-ddbefda383cccbf8d537b30471fc2ce893826d35.tar.bz2
libxkbcommon-ddbefda383cccbf8d537b30471fc2ce893826d35.zip
build: error out on undefined symbols
This helps ensure we don't ship a library with undefined symbols, which can easily happen with multiple inter-dependent DSOs. Signed-off-by: Ran Benita <ran234@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6775733..3168b55 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,6 +17,9 @@ AM_CPPFLAGS = \
AM_CFLAGS = $(BASE_CFLAGS)
AM_LDFLAGS = -no-undefined
+if HAVE_NO_UNDEFINED
+AM_LDFLAGS += -Wl,--no-undefined
+endif
AM_YFLAGS = -d -p _xkbcommon_