summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZack Weinberg <zackw@panix.com>2021-03-18 08:34:56 -0400
committerZack Weinberg <zackw@panix.com>2021-03-18 08:34:56 -0400
commitf0ca1fe2275381f37b21faede6ae873986636254 (patch)
treee6d36c4ddd87d09f8b8d789c61ed2fa174aff1cf /configure.ac
parent86d1e4e3815fa6c47613bda86820ee50e41ebd11 (diff)
downloadlibxcrypt-f0ca1fe2275381f37b21faede6ae873986636254.tar.gz
libxcrypt-f0ca1fe2275381f37b21faede6ae873986636254.tar.bz2
libxcrypt-f0ca1fe2275381f37b21faede6ae873986636254.zip
configure.ac: error out if compute-symver-floor returns nothing.
This _should_ only ever happen if there’s some sort of low-level failure. These are already being logged in config.log, but we shouldn’t allow configure to succeed when they happen. We have a report of “sporadic” build failures due to this oversight (issue #123). This patch will only move the failure from the make step to the configure step, but hopefully that will make debugging easier.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e97844..83a6454 100644
--- a/configure.ac
+++ b/configure.ac
@@ -441,6 +441,9 @@ if test $enable_obsolete_api = 1; then
)
AC_MSG_RESULT([$SYMVER_FLOOR])
case "$SYMVER_FLOOR" in
+ '')
+ AC_MSG_ERROR([compute-symver-floor failed, see config.log for details])
+ ;;
ERROR)
AC_MSG_ERROR([libxcrypt port to $host is incomplete])
;;