summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZack Weinberg <zackw@panix.com>2020-01-17 13:45:02 -0500
committerZack Weinberg <zackw@panix.com>2020-01-17 13:45:02 -0500
commite99ddb58c78ba558e309253e60653489afe1b1ec (patch)
tree60a240de5063b003c1757a4a9817f12d9f310274 /configure.ac
parent5af8a94068e2cddf1c2173614f76bb1ca7c3fdfd (diff)
downloadlibxcrypt-e99ddb58c78ba558e309253e60653489afe1b1ec.tar.gz
libxcrypt-e99ddb58c78ba558e309253e60653489afe1b1ec.tar.bz2
libxcrypt-e99ddb58c78ba558e309253e60653489afe1b1ec.zip
Rename lib/hashes.lst to lib/hashes.conf.
The ‘codecov’ utility, used in CI to upload coverage reports, thinks any file with a ‘.lst’ extension is a coverage report. hashes.conf should give humans an equally sensible impression of the file contents, and shouldn’t be mistaken for any sort of generated data file by automation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bbb22c5..49041da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -366,7 +366,7 @@ AC_ARG_ENABLE([hashes],
[--enable-hashes=HASHES],
[Select hash methods to support. Acceptable values are
'all' or a comma-separated list of names from the file
- 'hashes.lst' and/or the keywords 'strong', 'alt',
+ 'hashes.conf' and/or the keywords 'strong', 'alt',
'fedora', 'freebsd', 'glibc', 'netbsd', 'openbsd',
'osx', 'owl', 'solaris', and 'suse' which select groups
of methods as described in that file.
@@ -382,7 +382,7 @@ AC_ARG_ENABLE([hashes],
hashes_enabled=$(
$AWK -f ${srcdir}/lib/sel-hashes.awk \
-v SELECTED_HASHES="$hashes_selected" \
- ${srcdir}/lib/hashes.lst
+ ${srcdir}/lib/hashes.conf
)
if test x"$hashes_enabled" = x || test x"$hashes_enabled" = x,; then
AC_MSG_ERROR([bad value '${hashes_selected}' for --enable-hashes])