summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2018-11-13 15:31:12 +0100
committerBjörn Esser <besser82@fedoraproject.org>2018-11-14 18:56:53 +0100
commit91e267c1e2599374d7f86897ae8b670d72d8474a (patch)
tree80d74be796dcad1b509184c8d02d9d62e35b5cbc /configure.ac
parent9e9835dcb73a7576565893035e80fdc1ca795789 (diff)
downloadlibxcrypt-91e267c1e2599374d7f86897ae8b670d72d8474a.tar.gz
libxcrypt-91e267c1e2599374d7f86897ae8b670d72d8474a.tar.bz2
libxcrypt-91e267c1e2599374d7f86897ae8b670d72d8474a.zip
Install <xcrypt.h> and a symlink from libxcrypt.so to libcrypt.so.
This is needed as some configure scripts may look for symbols available in libxcrypt.so. For static libraries a corresponding symlink for the archive file will be installed. The installation of those compatibility files can be disabled by passing the '--disable-xcrypt-compat-files' flag to the configure script.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d3f5b2f..2c2c359 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,6 +212,20 @@ AC_DEFINE_UNQUOTED([ENABLE_FAILURE_TOKENS], [$enable_failure_tokens],
[Define to 1 if crypt and crypt_r should return a "failure token" on
failure, or 0 if they should return NULL.])
+AC_ARG_ENABLE([xcrypt-compat-files],
+ AS_HELP_STRING(
+ [--disable-xcrypt-compat-files],
+ [Disable the installation of the <xcrypt.h> header file and the
+ libxcrypt.{a,so} compatibility symlinks.]
+ ),
+ [case "$enableval" in
+ yes) enable_xcrypt_compat_files=1;;
+ no) enable_xcrypt_compat_files=0;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-xcrypt-compat-files]);;
+ esac],
+ [enable_xcrypt_compat_files=1])
+AM_CONDITIONAL([ENABLE_XCRYPT_COMPAT_FILES], [test x"$enable_xcrypt_compat_files" = x1])
+
AC_ARG_ENABLE([obsolete-api],
AS_HELP_STRING(
[--enable-obsolete-api[=ARG]],