summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2018-08-02 09:44:07 +0200
committerBjörn Esser <besser82@fedoraproject.org>2018-08-02 10:02:32 +0200
commit7281ceb60e404e8734784670490aaf7d95ffb970 (patch)
tree8f72cad095e35fca4378213ef9fb0356c9de24e1 /configure.ac
parent0e5a38cde2ede896e4dca6d85f133d9e23ec72cc (diff)
downloadlibxcrypt-7281ceb60e404e8734784670490aaf7d95ffb970.tar.gz
libxcrypt-7281ceb60e404e8734784670490aaf7d95ffb970.tar.bz2
libxcrypt-7281ceb60e404e8734784670490aaf7d95ffb970.zip
Use valgrind memcheck if available to test for memory leaks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8940e2d..9ea30f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,6 @@ AC_C_BIGENDIAN(
AC_DEFINE([IS_BIGENDIAN], 0,
[Define to 0 if system's architecture is little-endian.])
)
-
# One of the test scripts needs to use -dD.
AC_CACHE_CHECK([whether the preprocessor ($CPP) supports -dD],
[ac_cv_prog_cc_dD],
@@ -151,8 +150,18 @@ AC_CHECK_FUNCS_ONCE([
syscall
])
-# Configure options.
+# Disable valgrind tools for checking multithreaded
+# programs, as we don't use them in checks.
+AX_VALGRIND_DFLT([drd], [off])
+AX_VALGRIND_DFLT([helgrind], [off])
+
+# Valgrind's sgcheck is b0rk3n upstream.
+AX_VALGRIND_DFLT([sgcheck], [off])
+# Add a target to run testsuite with valgrind.
+AX_VALGRIND_CHECK()
+
+# Configure options.
AC_ARG_ENABLE([obsolete-api],
AS_HELP_STRING(
[--enable-obsolete-api[=ARG]],