summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZack Weinberg <zackw@panix.com>2020-12-14 18:13:44 -0500
committerZack Weinberg <zackw@panix.com>2020-12-31 17:01:35 -0500
commit3436c6a94b8d565bf236bb916ebd3ade28834496 (patch)
treefa51a2c9e57f45aee0b42fa5368cca48e9c823be /configure.ac
parent941a32bb879d5228246bdb162c9fb44788c8387a (diff)
downloadlibxcrypt-3436c6a94b8d565bf236bb916ebd3ade28834496.tar.gz
libxcrypt-3436c6a94b8d565bf236bb916ebd3ade28834496.tar.bz2
libxcrypt-3436c6a94b8d565bf236bb916ebd3ade28834496.zip
Move most scripts to top-level build-aux directory.
Since we might not want to keep the build scripts as a combination of sh + awk forever, move most of them to a new top-level directory and rename them without any .sh or .awk suffixes. This directory is named build-aux, consistent with the recommendations in the autoconf manual, and all of the .m4 files extending autoconf move there as well. The shell scripts in test/ remain there, so that all of the tests stay together, and they keep their .sh suffix, because this is how Automake knows that they are not C programs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 79ae7d4..b42c570 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,12 +1,12 @@
# Process this file with autoconf to produce a configure script.
-m4_include([m4/zw_automodern.m4])
+m4_include([build-aux/zw_automodern.m4])
AC_INIT([xcrypt],
[4.4.18],
[https://github.com/besser82/libxcrypt/issues],
[libxcrypt],
[https://github.com/besser82/libxcrypt])
-AC_CONFIG_MACRO_DIR([m4])
-AC_CONFIG_AUX_DIR([m4])
+AC_CONFIG_MACRO_DIR([build-aux])
+AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_SRCDIR([lib/crypt.c])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([
@@ -369,7 +369,7 @@ AC_ARG_ENABLE([hashes],
)
# This code must run after AC_PROG_AWK.
hashes_enabled=$(
- $AWK -f ${srcdir}/lib/sel-hashes.awk \
+ $AWK -f ${srcdir}/build-aux/expand-selected-hashes \
-v SELECTED_HASHES="$hashes_selected" \
${srcdir}/lib/hashes.conf
)