summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZack Weinberg <zackw@panix.com>2021-03-07 10:45:29 -0500
committerZack Weinberg <zackw@panix.com>2021-03-07 10:45:29 -0500
commit44e9eb57b462cfbaeb085cea0e308511565f4a12 (patch)
tree1b31bb608d906262e080e22062294b78d8fbe507 /Makefile.am
parent1d1e0a53dd26d4b00583f1f9db91f8b7295395d4 (diff)
downloadlibxcrypt-44e9eb57b462cfbaeb085cea0e308511565f4a12.tar.gz
libxcrypt-44e9eb57b462cfbaeb085cea0e308511565f4a12.tar.bz2
libxcrypt-44e9eb57b462cfbaeb085cea0e308511565f4a12.zip
Remove redundant byte order conversion functions.
alg-yescrypt-sysendian.h provides the same set of functions that byteorder.h does, just with different names. Have byteorder.h provide both sets of names, and remove alg-yescrypt-sysendian.h. Also, move the vectorized byte order conversion functions from alg-sha{256,512}.c to byteorder.h, normalize their API, and generate them from template macros so it’s easy to add more in the future if we need them. Push the warning suppression pragmas from alg-yescrypt-sysendian.h down into the one .c file that actually needs them, alg-yescrypt-opt.c. I am a little worried that these are papering over actual latent bugs--we use the aggressive conversion warnings for a reason--but that’s not today’s project.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fe19393..1899fc6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,7 +75,6 @@ noinst_HEADERS = \
lib/alg-sha1.h \
lib/alg-sha256.h \
lib/alg-sha512.h \
- lib/alg-yescrypt-sysendian.h \
lib/alg-yescrypt.h \
lib/byteorder.h \
lib/crypt-common.h \