summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2018-12-08 14:10:29 +0100
committerBjörn Esser <besser82@fedoraproject.org>2018-12-08 18:24:17 +0100
commite07290ec7c3de301ce2b813ee2b42131bef2b119 (patch)
tree05d77554eeb1af0be8e20d4485b70e0e8249becd /Makefile.am
parenta2a39c9ea85dfd5afe4d1f54687bba0f4ed49273 (diff)
downloadlibxcrypt-e07290ec7c3de301ce2b813ee2b42131bef2b119.tar.gz
libxcrypt-e07290ec7c3de301ce2b813ee2b42131bef2b119.tar.bz2
libxcrypt-e07290ec7c3de301ce2b813ee2b42131bef2b119.zip
Add test-alg-yescrypt from upstream for improved coverage.
This also needs to re-add those functions from the upstream codebase, which have been dropped on intial integration of yescrypt with libxcrypt.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index f73412a..907e80e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -223,14 +223,15 @@ check_PROGRAMS = \
test-alg-des test-alg-gost3411-2012 test-alg-gost3411-2012-hmac \
test-alg-hmac-sha1 test-alg-md4 test-alg-md5 \
test-alg-pbkdf-hmac-sha256 test-alg-sha1 test-alg-sha256 \
- test-alg-sha512 test-checksalt test-crypt-bcrypt test-crypt-des \
- test-crypt-gost-yescrypt test-crypt-md5 test-crypt-nthash \
- test-crypt-pbkdf1-sha1 test-crypt-scrypt test-crypt-sha256 \
- test-crypt-sha512 test-crypt-sunmd5 test-crypt-yescrypt \
- test-byteorder test-badsalt test-badsetting test-gensalt \
- test-gensalt-extradata test-gensalt-nthash test-preferred-method \
- test-crypt-badargs test-short-outbuf test-compile-strong-alias \
- test-getrandom-interface test-getrandom-fallbacks
+ test-alg-sha512 test-alg-yescrypt test-checksalt test-crypt-bcrypt \
+ test-crypt-des test-crypt-gost-yescrypt test-crypt-md5 \
+ test-crypt-nthash test-crypt-pbkdf1-sha1 test-crypt-scrypt \
+ test-crypt-sha256 test-crypt-sha512 test-crypt-sunmd5 \
+ test-crypt-yescrypt test-byteorder test-badsalt test-badsetting \
+ test-gensalt test-gensalt-extradata test-gensalt-nthash \
+ test-preferred-method test-crypt-badargs test-short-outbuf \
+ test-compile-strong-alias test-getrandom-interface \
+ test-getrandom-fallbacks
if ENABLE_OBSOLETE_API
libcrypt_la_SOURCES += crypt-des-obsolete.c
@@ -329,6 +330,11 @@ test_alg_sha256_LDADD = \
test_alg_sha512_LDADD = \
libcrypt_la-alg-sha512.lo \
$(COMMON_TEST_OBJECTS)
+test_alg_yescrypt_LDADD = \
+ libcrypt_la-alg-sha256.lo \
+ libcrypt_la-alg-yescrypt-common.lo \
+ libcrypt_la-alg-yescrypt-opt.lo \
+ $(COMMON_TEST_OBJECTS)
test_crypt_gost_yescrypt_LDADD = \
libcrypt_la-alg-gost3411-2012-core.lo \
libcrypt_la-alg-gost3411-2012-hmac.lo \