summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2017-10-22 23:54:00 +0200
committerBjörn Esser <besser82@fedoraproject.org>2017-10-23 00:00:19 +0200
commit5dfada2fe82ab4ddb5d97ccbe6315b51bb3458d6 (patch)
treebdeef456142fe75b41e2892521a2fa1c943ac874 /Makefile.am
parent4f2bbab55c00ed4aaefad7375a6574021e1c7e00 (diff)
downloadlibxcrypt-5dfada2fe82ab4ddb5d97ccbe6315b51bb3458d6.tar.gz
libxcrypt-5dfada2fe82ab4ddb5d97ccbe6315b51bb3458d6.tar.bz2
libxcrypt-5dfada2fe82ab4ddb5d97ccbe6315b51bb3458d6.zip
test-crypt-nonnull: Test for crypt_r{a,n} returning non-NULL on error
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 246bc9b..1cb9b33 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -109,7 +109,7 @@ endif
check_PROGRAMS = \
test-alg-sha256 test-alg-sha512 \
test-crypt-sha256 test-crypt-sha512 test-crypt-bcrypt \
- test-byteorder test-gensalt
+ test-crypt-nonnull test-byteorder test-gensalt
if ENABLE_WEAK_HASHES
libcrypt_la_SOURCES += \
@@ -179,6 +179,7 @@ test_crypt_badsalt_LDADD = libcrypt.la
test_crypt_bcrypt_LDADD = libcrypt.la
test_crypt_des_LDADD = libcrypt.la
test_crypt_md5_LDADD = libcrypt.la
+test_crypt_nonnull_LDADD = libcrypt.la
test_crypt_nthash_LDADD = libcrypt.la
test_crypt_sha256_LDADD = libcrypt.la
test_crypt_sha512_LDADD = libcrypt.la