summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2019-02-07 21:17:33 +0100
committerBjörn Esser <besser82@fedoraproject.org>2019-02-07 21:17:33 +0100
commit0f0c90ab7b8dd9d21ae00443b30999c847e9aaca (patch)
tree8f41c45c8966c308c7005fe83aab84b6fb4ff1cb /Makefile.am
parent0a7ada6dbf00a025e0f25768a3493811dd4763b5 (diff)
downloadlibxcrypt-0f0c90ab7b8dd9d21ae00443b30999c847e9aaca.tar.gz
libxcrypt-0f0c90ab7b8dd9d21ae00443b30999c847e9aaca.tar.bz2
libxcrypt-0f0c90ab7b8dd9d21ae00443b30999c847e9aaca.zip
Do not use hardcoded Python executable in Makefile.
We need at least Python >= 3.6 and several Python modules to run test-crypt-kat-gen.py for updating test-crypt-kat.inc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cdf21cd..41a3aa3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -243,19 +243,21 @@ check_PROGRAMS = \
# headers used only by test programs
noinst_HEADERS += test-crypt-kat.inc
+if ENABLE_CRYPT_KAT_GEN
if ENABLE_SHARED
# test-crypt-kat.inc can be regenerated by running test-crypt-kat-gen.py.
# This is very slow and requires nonstandard Python libraries and a shared
# library build of libcrypt already present in the build-tree, so we only
# do it when explicitly requested.
regen-test-crypt-kat: libcrypt.la
- python3 $(srcdir)/test-crypt-kat-gen.py > test-crypt-kat.inc.T
+ $(PYTHON) $(srcdir)/test-crypt-kat-gen.py > test-crypt-kat.inc.T
@if cmp -s test-crypt-kat.inc.T $(srcdir)/test-crypt-kat.inc; \
then echo test-crypt-kat.inc is unchanged; rm test-crypt-kat.inc.T; \
else echo mv -f test-crypt-kat.inc.T $(srcdir)/test-crypt-kat.inc; \
mv -f test-crypt-kat.inc.T $(srcdir)/test-crypt-kat.inc; fi
phony_targets += regen-test-crypt-kat
endif
+endif
if ENABLE_OBSOLETE_API
libcrypt_la_SOURCES += crypt-des-obsolete.c