summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2019-01-22 14:19:19 +0100
committerBjörn Esser <besser82@fedoraproject.org>2019-01-24 19:15:33 +0100
commit0919e33d0e12bf580ce389456e73ce3b88afd771 (patch)
treef82568c6290efec1ba15b5ca8020de2eb50d46d0 /Makefile.am
parent951f998a6a542977331ca4cdda64a0ca6222043a (diff)
downloadlibxcrypt-0919e33d0e12bf580ce389456e73ce3b88afd771.tar.gz
libxcrypt-0919e33d0e12bf580ce389456e73ce3b88afd771.tar.bz2
libxcrypt-0919e33d0e12bf580ce389456e73ce3b88afd771.zip
Add --enable-obsolete-api-enosys configure option.
If enabled, this option replaces the obsolete APIs (fcrypt, encrypt{,_r}, and setkey{,_r}) with stubs that set errno to ENOSYS and return without performing any real operations. This allows one to disable DEScrypt support while preserving POSIX compliance. For security reasons, the encrypt{,r} functions will also overwrite their data-block argument with random bits. The fcrypt function will always produce a failure token (*0 or *1), unless the library was also configured with --disable-failure-tokens, in which case it will always return NULL.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b04880..99a6b27 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -243,7 +243,7 @@ check_PROGRAMS = \
if ENABLE_OBSOLETE_API
libcrypt_la_SOURCES += crypt-des-obsolete.c
-check_PROGRAMS += test-des-obsolete test-des-obsolete_r
+check_PROGRAMS += test-des-obsolete test-des-obsolete_r test-fcrypt-enosys
endif
TESTS = $(check_PROGRAMS)
@@ -298,6 +298,7 @@ test_gensalt_extradata_LDADD = $(COMMON_TEST_OBJECTS)
test_checksalt_LDADD = $(COMMON_TEST_OBJECTS)
test_des_obsolete_LDADD = $(COMMON_TEST_OBJECTS)
test_des_obsolete_r_LDADD = $(COMMON_TEST_OBJECTS)
+test_fcrypt_enosys_LDADD = $(COMMON_TEST_OBJECTS)
test_crypt_badargs_LDADD = $(COMMON_TEST_OBJECTS)
test_short_outbuf_LDADD = $(COMMON_TEST_OBJECTS)
test_preferred_method_LDADD = $(COMMON_TEST_OBJECTS)