summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2018-11-01 21:31:35 +0100
committerBjörn Esser <besser82@fedoraproject.org>2018-11-03 12:10:47 +0100
commit00c7a9c7b8d38c86720a2a6f38ab5590181b74fc (patch)
tree49c048c312513c3227dfb46b7827d039382df4af /Makefile.am
parentf3177ccdfacfa79c7f4f5696b05787dd1776823a (diff)
downloadlibxcrypt-00c7a9c7b8d38c86720a2a6f38ab5590181b74fc.tar.gz
libxcrypt-00c7a9c7b8d38c86720a2a6f38ab5590181b74fc.tar.bz2
libxcrypt-00c7a9c7b8d38c86720a2a6f38ab5590181b74fc.zip
Move helper functions into 'crypt-common.c'.
Inlining these functions into exery compilation unit take time and wastes space in the library. Additonally some compilers complain about unused inline functions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1686a87..fc14dff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,7 +45,7 @@ libcrypt_la_SOURCES = \
crypt-gensalt-static.c crypt-gensalt.c crypt-gost-yescrypt.c \
crypt-md5.c crypt-nthash.c crypt-pbkdf1-sha1.c crypt-scrypt.c \
crypt-sha256.c crypt-sha512.c crypt-static.c crypt-sunmd5.c \
- crypt-yescrypt.c randombytes.c
+ crypt-yescrypt.c randombytes.c crypt-common.c
EXTRA_DIST += alg-yescrypt-platform.c
@@ -219,7 +219,7 @@ test_crypt_sunmd5_LDADD = libcrypt.la
test_crypt_yescrypt_LDADD = libcrypt.la
test_badsalt_LDADD = libcrypt.la
test_badsetting_LDADD = libcrypt.la
-test_gensalt_LDADD = libcrypt.la
+test_gensalt_LDADD = crypt-common.lo libcrypt.la
test_des_obsolete_LDADD = libcrypt.la
test_des_obsolete_r_LDADD = libcrypt.la
test_crypt_badargs_LDADD = libcrypt.la
@@ -242,7 +242,7 @@ test_alg_sha512_LDADD = alg-sha512.lo
test_crypt_gost_yescrypt_LDADD = alg-gost3411-2012-core.lo \
alg-gost3411-2012-hmac.lo alg-sha256.lo \
alg-yescrypt-common.lo alg-yescrypt-opt.lo \
- crypt-yescrypt.lo libcrypt.la
+ crypt-yescrypt.lo crypt-common.lo libcrypt.la
test_getrandom_interface_LDADD = randombytes.lo
test_getrandom_fallbacks_LDADD = randombytes.lo