summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-08-06 16:11:47 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-08-06 19:11:21 +0200
commit41ceaf0fd179627960ae186f5fc3099e99157339 (patch)
treedbe58f5f50f2f2f2e0bcd812120d2d55483fa665 /configure.ac
parent391c10c6590460300613a0316cea6cd3c479ba70 (diff)
downloadlibva-intel-driver-41ceaf0fd179627960ae186f5fc3099e99157339.tar.gz
libva-intel-driver-41ceaf0fd179627960ae186f5fc3099e99157339.tar.bz2
libva-intel-driver-41ceaf0fd179627960ae186f5fc3099e99157339.zip
wayland: drop explicit dependencies to Wayland libraries.
Signed-off-by: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ce80d17..f56c4b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,21 +151,13 @@ AM_CONDITIONAL(USE_EGL, test "$USE_EGL" = "yes")
# Check for Wayland
USE_WAYLAND="no"
-WAYLAND_DRM_CFLAGS=""
-WAYLAND_DRM_LIBS=""
if test "$enable_wayland" = "yes"; then
PKG_CHECK_MODULES([WAYLAND], [wayland-client], [USE_WAYLAND="yes"], [:])
PKG_CHECK_MODULES([LIBVA_WAYLAND_DEPS], [libva-wayland],
[AC_DEFINE([HAVE_VA_WAYLAND], [1], [Defined to 1 if VA/Wayland API is enabled])],
[USE_WAYLAND="no"])
- if test "$USE_EGL" = "yes"; then
- WAYLAND_DRM_CFLAGS="$DRM_CFLAGS"
- WAYLAND_DRM_LIBS="$DRM_LIBS $EGL_LIBS"
- fi
fi
AM_CONDITIONAL(USE_WAYLAND, test "$USE_WAYLAND" = "yes")
-AC_SUBST([WAYLAND_DRM_CFLAGS])
-AC_SUBST([WAYLAND_DRM_LIBS])
m4_ifdef([WAYLAND_SCANNER_RULES],
[WAYLAND_SCANNER_RULES(['$(top_srcdir)/src/wayland'])],