summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..01feea4
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,14 @@
+check_PROGRAMS = test
+test_SOURCES = test.c usbg-test.c usbg-io-wrappers.c
+test_LDFLAGS = -ldl
+test_LDFLAGS += $(CMOCKA_LIBS)
+test_LDFLAGS += $(LIBCONFIG_LIBS)
+test_LDADD = ./libusbgx.so
+test_CPPFLAGS = -I$(top_srcdir)/include/
+
+./libusbgx.so:
+ -ln -s $(top_srcdir)/src/.libs/libusbgx.so* .
+CLEANFILES = libusbgx.so*
+
+check_SCRIPTS = ./test.sh
+TESTS = $(check_SCRIPTS)