summaryrefslogtreecommitdiff
path: root/src/thbrk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/thbrk/Makefile.am')
-rw-r--r--src/thbrk/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/thbrk/Makefile.am b/src/thbrk/Makefile.am
new file mode 100644
index 0000000..aea13e6
--- /dev/null
+++ b/src/thbrk/Makefile.am
@@ -0,0 +1,19 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+dictdatadir = $(datadir)/libthai
+
+INCLUDES = -I. -I$(top_srcdir)/include $(DATRIE_CFLAGS)
+DEFS = -DDICT_DIR=\"$(dictdatadir)\"
+
+noinst_LTLIBRARIES = libthbrk.la
+
+libthbrk_la_SOURCES = \
+ thbrk.c \
+ thbrk-private.h \
+ brk-ctype.c \
+ brk-ctype.h \
+ brk-maximal.c \
+ brk-maximal.h
+
+libthbrk_la_LIBADD = $(DATRIE_LIBS)
+