summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-04 07:14:38 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-04 07:14:38 -0800
commite28c3fb0c3efaee49f10d1aa87e5eb9170cdf17a (patch)
tree87c37522bc6462b73c5f327716e8063f8387ec34 /src/Makefile.am
downloadlibthai-e28c3fb0c3efaee49f10d1aa87e5eb9170cdf17a.tar.gz
libthai-e28c3fb0c3efaee49f10d1aa87e5eb9170cdf17a.tar.bz2
libthai-e28c3fb0c3efaee49f10d1aa87e5eb9170cdf17a.zip
Imported Upstream version 0.1.18upstream/0.1.18upstream
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..36bbe63
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,37 @@
+SUBDIRS = thctype thstr thcell thinp thrend thcoll thbrk thwchar thwctype \
+ thwstr thwbrk
+
+MAINTAINERCLEANFILES = Makefile.in
+
+EXTRA_DIST = libthai.map libthai.def
+
+lib_LTLIBRARIES = libthai.la
+
+libthai_sublibs = \
+ $(top_builddir)/src/thctype/libthctype.la \
+ $(top_builddir)/src/thstr/libthstr.la \
+ $(top_builddir)/src/thcell/libthcell.la \
+ $(top_builddir)/src/thinp/libthinp.la \
+ $(top_builddir)/src/thrend/libthrend.la \
+ $(top_builddir)/src/thcoll/libthcoll.la \
+ $(top_builddir)/src/thbrk/libthbrk.la \
+ $(top_builddir)/src/thwchar/libthwchar.la \
+ $(top_builddir)/src/thwctype/libthwctype.la \
+ $(top_builddir)/src/thwstr/libthwstr.la \
+ $(top_builddir)/src/thwbrk/libthwbrk.la
+
+if LD_HAS_VERSION_SCRIPT
+EXPORTS_FLAGS = -Wl,-version-script -Wl,$(srcdir)/libthai.map
+EXPORTS_DEPS = libthai.map
+else
+EXPORTS_FLAGS = -export-symbols $(srcdir)/libthai.def
+EXPORTS_DEPS = libthai.def
+endif
+
+libthai_la_SOURCES = libthai.c
+libthai_la_LIBADD = $(libthai_sublibs)
+libthai_la_LDFLAGS = -no-undefined \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
+ $(EXPORTS_FLAGS)
+libthai_la_DEPENDENCIES = $(EXPORTS_DEPS) $(libthai_sublibs)
+