summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-04 07:14:38 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-04 07:14:38 -0800
commite28c3fb0c3efaee49f10d1aa87e5eb9170cdf17a (patch)
tree87c37522bc6462b73c5f327716e8063f8387ec34 /doc/Makefile.am
downloadlibthai-e28c3fb0c3efaee49f10d1aa87e5eb9170cdf17a.tar.gz
libthai-e28c3fb0c3efaee49f10d1aa87e5eb9170cdf17a.tar.bz2
libthai-e28c3fb0c3efaee49f10d1aa87e5eb9170cdf17a.zip
Imported Upstream version 0.1.18upstream/0.1.18upstream
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..425aa3b
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,29 @@
+if ENABLE_DOXYGEN_DOC
+
+all-local: doxygen.stamp
+
+doxygen.stamp: $(top_srcdir)/include/thai/*.h $(top_srcdir)/src/*/*.c
+ $(DOXYGEN)
+ touch doxygen.stamp
+
+install-data-local: install-html
+
+install-html:
+ $(INSTALL) -d $(DESTDIR)$(htmldocdir)
+ $(INSTALL_DATA) html/* $(DESTDIR)$(htmldocdir)
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(htmldocdir)
+
+clean-local:
+ rm -rf html
+ rm -f doxygen.stamp
+
+else
+
+install-data-local:
+uninstall-local:
+clean-local:
+
+endif
+