summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am56
1 files changed, 33 insertions, 23 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 5a0077b..40551b3 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,5 +1,5 @@
## Process this file with automake to produce Makefile.in
-# Copyright (C) 2002-2014 Free Software Foundation, Inc.
+# Copyright (C) 2002-2022 Free Software Foundation, Inc.
#
# This file is part of LIBTASN1.
#
@@ -16,41 +16,49 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-SUBDIRS = cyclo
if ENABLE_GTK_DOC
-SUBDIRS += reference
+SUBDIRS = reference
endif
-EXTRA_DIST = gdoc TODO libtasn1.html libtasn1.ps libtasn1.pdf stamp_docs \
- COPYING COPYING.LESSER
+EXTRA_DIST = gdoc TODO stamp_docs COPYING COPYING.LESSER
info_TEXINFOS = libtasn1.texi
-libtasn1_TEXINFOS = fdl-1.3.texi texinfo.css $(gdoc_TEXINFOS)
+libtasn1_TEXINFOS = fdl-1.3.texi $(gdoc_TEXINFOS)
+libtasn1_TEXINFOS += asn1Coding-help.texi asn1Decoding-help.texi asn1Parser-help.texi
-AM_MAKEINFOFLAGS = -I $(top_builddir)/doc
-TEXI2DVI = texi2dvi $(AM_MAKEINFOFLAGS)
-AM_MAKEINFOHTMLFLAGS = $(AM_MAKEINFOFLAGS) \
- --no-split --number-sections --css-include=texinfo.css
+AM_MAKEINFOHTMLFLAGS = --no-split $(AM_MAKEINFOFLAGS)
dist_man_MANS = $(gdoc_MANS) asn1Parser.1 asn1Coding.1 asn1Decoding.1
HELP2MAN_OPTS = --info-page libtasn1
-asn1Parser.1: $(top_srcdir)/src/asn1Parser.c $(top_srcdir)/configure.ac
- $(HELP2MAN) $(HELP2MAN_OPTS) \
- --name="ASN.1 syntax tree generator for libtasn1" \
- --output=$@ $(top_builddir)/src/asn1Parser$(EXEEXT)
-
-asn1Coding.1: $(top_srcdir)/src/asn1Coding.c $(top_srcdir)/configure.ac
- $(HELP2MAN) $(HELP2MAN_OPTS) \
+asn1Coding.1: $(top_srcdir)/src/asn1Coding.c $(top_srcdir)/.version
+ $(AM_V_GEN)$(HELP2MAN) $(HELP2MAN_OPTS) \
--name="ASN.1 DER encoder" \
--output=$@ $(top_builddir)/src/asn1Coding$(EXEEXT)
-asn1Decoding.1: $(top_srcdir)/src/asn1Decoding.c $(top_srcdir)/configure.ac
- $(HELP2MAN) $(HELP2MAN_OPTS) \
+asn1Decoding.1: $(top_srcdir)/src/asn1Decoding.c $(top_srcdir)/.version
+ $(AM_V_GEN)$(HELP2MAN) $(HELP2MAN_OPTS) \
--name="ASN.1 DER decoder" \
--output=$@ $(top_builddir)/src/asn1Decoding$(EXEEXT)
+asn1Parser.1: $(top_srcdir)/src/asn1Parser.c $(top_srcdir)/.version
+ $(AM_V_GEN)$(HELP2MAN) $(HELP2MAN_OPTS) \
+ --name="ASN.1 syntax tree generator for libtasn1" \
+ --output=$@ $(top_builddir)/src/asn1Parser$(EXEEXT)
+
+asn1Coding-help.texi: $(top_srcdir)/src/asn1Coding.c
+ $(AM_V_GEN)$(top_builddir)/src/asn1Coding$(EXEEXT) --help > tmp-$@ && \
+ mv tmp-$@ asn1Coding-help.texi
+
+asn1Decoding-help.texi: $(top_srcdir)/src/asn1Decoding.c
+ $(AM_V_GEN)$(top_builddir)/src/asn1Decoding$(EXEEXT) --help > tmp-$@ && \
+ mv tmp-$@ asn1Decoding-help.texi
+
+asn1Parser-help.texi: $(top_srcdir)/src/asn1Parser.c
+ $(AM_V_GEN)$(top_builddir)/src/asn1Parser$(EXEEXT) --help > tmp-$@ && \
+ mv tmp-$@ asn1Parser-help.texi
+
gdoc_MANS =
gdoc_MANS += man/asn1_get_length_der.3
gdoc_MANS += man/asn1_get_tag_der.3
@@ -72,6 +80,7 @@ gdoc_MANS += man/asn1_find_node.3
gdoc_MANS += man/asn1_length_der.3
gdoc_MANS += man/asn1_octet_der.3
gdoc_MANS += man/asn1_encode_simple_der.3
+gdoc_MANS += man/asn1_object_id_der.3
gdoc_MANS += man/asn1_bit_der.3
gdoc_MANS += man/asn1_der_coding.3
gdoc_MANS += man/asn1_write_value.3
@@ -122,6 +131,7 @@ gdoc_TEXINFOS += texi/asn1_find_node.texi
gdoc_TEXINFOS += texi/asn1_length_der.texi
gdoc_TEXINFOS += texi/asn1_octet_der.texi
gdoc_TEXINFOS += texi/asn1_encode_simple_der.texi
+gdoc_TEXINFOS += texi/asn1_object_id_der.texi
gdoc_TEXINFOS += texi/asn1_bit_der.texi
gdoc_TEXINFOS += texi/asn1_der_coding.texi
gdoc_TEXINFOS += texi/asn1_write_value.texi
@@ -146,7 +156,7 @@ gdoc_TEXINFOS += texi/asn1_check_version.texi
GDOC_SRC = $(top_srcdir)/lib/decoding.c $(top_srcdir)/lib/errors.c \
$(top_srcdir)/lib/parser_aux.c $(top_srcdir)/lib/coding.c \
$(top_srcdir)/lib/element.c $(top_srcdir)/lib/gstr.c \
- $(top_srcdir)/lib/structure.c $(top_srcdir)/lib/ASN1.c \
+ $(top_srcdir)/lib/structure.c $(top_builddir)/lib/ASN1.c \
$(top_srcdir)/lib/version.c
compare-makefile:
@@ -161,7 +171,7 @@ compare-makefile:
MANS="$$MANS\ngdoc_MANS += man/$$i.3"; \
TEXINFOS="$$TEXINFOS\ngdoc_TEXINFOS += texi/$$i.texi"; \
done; \
- grep -v -e '^gdoc_MANS += ' -e '^gdoc_TEXINFOS += ' Makefile.am | \
+ grep -v -e '^gdoc_MANS += ' -e '^gdoc_TEXINFOS += ' $(srcdir)/Makefile.am | \
perl -p -e "s,^gdoc_MANS =,gdoc_MANS =$$MANS,;" | \
perl -p -e "s,^gdoc_TEXINFOS =,gdoc_TEXINFOS =$$TEXINFOS,;" \
> tmp-$@;
@@ -173,7 +183,7 @@ $(gdoc_MANS) $(gdoc_TEXINFOS): stamp_docs
clean-local:
-rm -f stamp_docs
-stamp_docs:
+stamp_docs: $(top_srcdir)/.version
$(mkdir_p) man texi; \
for i in `$(srcdir)/gdoc -listfunc $(GDOC_SRC)`; do \
echo -n "Creating documentation for $$i... " && \
@@ -183,7 +193,7 @@ stamp_docs:
-sourceversion $(VERSION) \
-include libtasn1.h \
-seeinfo $(PACKAGE) -verbatimcopying \
- -copyright "2006-2015 Free Software Foundation, Inc." \
+ -copyright "2006-2022 Free Software Foundation, Inc." \
-function $$i \
$(GDOC_SRC) > man/$$i.3 && \
$(srcdir)/gdoc -texinfo -function $$i \