summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3b445c6..45d0233 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,7 @@ dnl Process this file with autoconf to produce a configure script.
# along with this program. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ([2.61])
-AC_INIT([GNU Libtasn1],[4.12],[help-libtasn1@gnu.org])
+AC_INIT([GNU Libtasn1],[4.13],[help-libtasn1@gnu.org])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS(config.h)
@@ -29,7 +29,7 @@ AM_SILENT_RULES([yes])
# Interfaces added: AGE++
# Interfaces removed: AGE=0
AC_SUBST(LT_CURRENT, 11)
-AC_SUBST(LT_REVISION, 4)
+AC_SUBST(LT_REVISION, 5)
AC_SUBST(LT_AGE, 5)
AC_PROG_CC
@@ -84,6 +84,7 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wswitch-default" # Breaks on bison generated ASN1.c
nw="$nw -Wunsafe-loop-optimizations"
nw="$nw -Wstrict-overflow"
+ nw="$nw -Woverlength-strings" # Some tests use large strings
nw="$nw -Wsuggest-attribute=pure" # Is it worth using pure attributes?
gl_MANYWARN_ALL_GCC([ws])