summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a31301c..2a8698b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,10 +26,10 @@ EXTRA_DIST = windows/asn1-parser/asn1-parser.vcproj \
windows/test-parser/test-parser.vcproj \
windows/test-tree/test-tree.vcproj windows/libtasn14win.mk
-SUBDIRS = gl lib src examples tests
+SUBDIRS = gl lib src tests
if ENABLE_DOC
-SUBDIRS += doc
+SUBDIRS += doc examples
endif
ACLOCAL_AMFLAGS = -I m4 -I gl/m4 -I lib/glm4
@@ -52,5 +52,14 @@ abi-check:
abi-compliance-checker -abi -lib libtasn1 -old "$(srcdir)/devel/ABI-$$(uname -m).dump" -new $(TMPFILE)
@rm -f $(TMPFILE)
+abi-dump:
+ @mkdir -p devel/headers-tmp
+ @cp lib/libtasn1.h devel/headers-tmp
+ @abi-dumper lib/.libs/libtasn1.so -o "./devel/ABI-$$(uname -m).dump" -public-headers devel/headers-tmp
+ @rm -rf devel/headers-tmp
+
+
dist-hook: abi-check
make -C doc/ compare-makefile
+
+.PHONY: abi-dump abi-check