summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 27 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index e878df5..5a57fea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
## Process this file with automake to produce Makefile.in
-# Copyright (C) 2002-2014 Free Software Foundation, Inc.
+# Copyright (C) 2002-2022 Free Software Foundation, Inc.
#
# This file is part of LIBTASN1.
#
@@ -17,6 +17,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+AM_DISTCHECK_DVI_TARGET = html
EXTRA_DIST = windows/asn1-parser/asn1-parser.vcproj \
windows/asn1-parser/config.h windows/libtasn1.ncb \
@@ -24,11 +25,10 @@ EXTRA_DIST = windows/asn1-parser/asn1-parser.vcproj \
windows/gnulib/getopt.h windows/gnulib/gnulib.vcproj \
windows/libtasn1/libtasn1.vcproj \
windows/test-parser/test-parser.vcproj \
- windows/test-tree/test-tree.vcproj windows/libtasn14win.mk \
- CONTRIBUTING.md cfg.mk maint.mk AUTHORS NEWS ChangeLog \
- THANKS LICENSE
+ windows/test-tree/test-tree.vcproj windows/libtasn14win.mk
+EXTRA_DIST += cfg.mk maint.mk CONTRIBUTING.md README.md
-SUBDIRS = lib src tests
+SUBDIRS = lib src fuzz tests
if ENABLE_DOC
SUBDIRS += doc examples
@@ -36,9 +36,7 @@ endif
include $(top_srcdir)/aminclude_static.am
-ACLOCAL_AMFLAGS = -I m4 -I m4-gl
-
-EXTRA_DIST += cfg.mk maint.mk .clcopying README.md
+ACLOCAL_AMFLAGS = -I m4 -I src/gl/m4
ABIDW_COMMON = --no-show-locs --no-corpus-path
ABIGNORE_FILE = "$(top_srcdir)/devel/libtasn1.abignore"
@@ -59,7 +57,7 @@ abi-dump-latest: lib/libtasn1.la
abi-check-latest: lib/libtasn1.la
@echo "Checking whether the latest ABI dump matches"
- @abidiff --suppressions $(ABIGNORE_FILE) lib/.libs/libtasn1.so $(LIBGNUTLS_ABI_LAST_FILE) --hd2 "$(srcdir)/lib/includes/"; if test $$? != 0;then \
+ @abidiff --suppressions $(ABIGNORE_FILE) lib/.libs/libtasn1.so $(LIBGNUTLS_ABI_LAST_FILE) --hd2 "$(builddir)/lib/includes/"; if test $$? != 0;then \
echo "*********************************************************"; \
echo "libtasn1 ABI has changed; use 'make files-update' "; \
echo "and use 'git diff' to check correctness before committing"; \
@@ -72,9 +70,9 @@ abi-check-latest: lib/libtasn1.la
ABICHECK_COMMON = --no-added-syms
abi-check: lib/libtasn1.la
- @for file in $$(echo $(srcdir)/devel/libtasn1-*-$$(uname -m).abi);do \
+ for file in $$(echo $(srcdir)/devel/libtasn1-*-$$(uname -m).abi);do \
echo "Comparing libtasn1 with $$file"; \
- abidiff $${file} lib/.libs/libtasn1.so $(ABICHECK_COMMON) --suppressions $(ABIGNORE_FILE) --hd2 "$(srcdir)/lib/includes//"; \
+ abidiff $${file} lib/.libs/libtasn1.so $(ABICHECK_COMMON) --suppressions $(ABIGNORE_FILE) --hd2 "$(builddir)/lib/includes//"; \
if test $$? != 0;then \
echo "****************************************************************************"; \
echo "ABI check failed; If intentional add suppression in devel/libtasn1.abignore"; \
@@ -94,10 +92,25 @@ local-code-coverage-output: code-coverage-capture
clean-local: code-coverage-clean
distclean-local: code-coverage-dist-clean
-dist-hook:
- if test -d "$(top_srcdir)/devel";then \
- $(MAKE) -C $(top_srcdir) abi-check-latest; \
+# git-version-gen
+EXTRA_DIST += $(top_srcdir)/.version
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook: gen-ChangeLog
+ echo $(VERSION) > $(distdir)/.tarball-version
+ if test -d "$(top_srcdir)/devel"; then \
+ $(MAKE) -C $(top_builddir) abi-check-latest; \
make -C doc/ compare-makefile; \
fi
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog > \
+ $(distdir)/cl-t && \
+ { rm -f $(distdir)/ChangeLog && \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; } \
+ fi
+
.PHONY: abi-check abi-dump-versioned abi-dump-latest