summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2014-03-14 15:09:11 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2014-03-14 15:09:11 +0100
commitd84d6567ecdeeb00b2536f3c16bc4f599df23e49 (patch)
tree7b304ed6ad8898161380ae695c74a87968bac734 /tests/Makefile.am
parent05b093a2ef966fd02a2e93248194778b1caa2d55 (diff)
downloadlibtasn1-d84d6567ecdeeb00b2536f3c16bc4f599df23e49.tar.gz
libtasn1-d84d6567ecdeeb00b2536f3c16bc4f599df23e49.tar.bz2
libtasn1-d84d6567ecdeeb00b2536f3c16bc4f599df23e49.zip
Added self-check for recursive choices.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 10bdba1..8f8beb8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -23,7 +23,7 @@ AM_LDFLAGS = -no-install
LDADD = ../lib/libtasn1.la ../gl/libgnu.la
EXTRA_DIST = Test_parser.asn Test_tree.asn Test_tree_asn1_tab.c \
- Test_encoding.asn pkix.asn TestIndef.p12
+ Test_encoding.asn pkix.asn TestIndef.p12 choice.asn
# For crlf.
EXTRA_DIST += crlf.cer
@@ -34,11 +34,11 @@ dist_check_SCRIPTS += threadsafety
MOSTLYCLEANFILES = Test_parser_ERROR.asn
check_PROGRAMS = Test_parser Test_tree Test_encoding Test_indefinite \
- Test_errors Test_simple Test_overflow Test_strings
+ Test_errors Test_simple Test_overflow Test_strings Test_choice
TESTS = Test_parser Test_tree Test_encoding Test_indefinite \
Test_errors Test_simple Test_overflow crlf threadsafety \
- Test_strings
+ Test_strings Test_choice
TESTS_ENVIRONMENT = \
ASN1PARSER=$(srcdir)/Test_parser.asn \