summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@crystal.(none)>2008-11-03 21:46:03 +0200
committerNikos Mavrogiannopoulos <nmav@crystal.(none)>2008-11-03 21:46:03 +0200
commiteaac42b56f7f4294ae62aeb06c89222fe21f9264 (patch)
treed4489406f31aaada170b762157b9d2f13b41da4a /tests/Makefile.am
parenta3577bd15ee66d37f025d014457c9d1751cd19ab (diff)
downloadlibtasn1-eaac42b56f7f4294ae62aeb06c89222fe21f9264.tar.gz
libtasn1-eaac42b56f7f4294ae62aeb06c89222fe21f9264.tar.bz2
libtasn1-eaac42b56f7f4294ae62aeb06c89222fe21f9264.zip
* Optimized tree generation by adding a small_value field in every node.
If the node contains few data they will be stored there instead of a malloced buffer. * Added ability to DER decoder to decode BER encoded octet strings. * Added test case with a pkcs-12 formatted structure to test the ability to parse those strings. * Added asn1_append_value() and asn1_set_value_octet() to reduce code being copied.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 512e01a..160a678 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -22,7 +22,7 @@ AM_LDFLAGS = -no-install
LDADD = ../lib/libtasn1.la
EXTRA_DIST = Test_parser.asn Test_tree.asn Test_tree_asn1_tab.c \
- Test_encoding.asn
+ Test_encoding.asn pkix.asn TestIndef.p12
# For crlf.
EXTRA_DIST += crlf.cer
@@ -30,12 +30,15 @@ dist_check_SCRIPTS = crlf
MOSTLYCLEANFILES = Test_parser_ERROR.asn
-check_PROGRAMS = Test_parser Test_tree Test_encoding
+check_PROGRAMS = Test_parser Test_tree Test_encoding Test_indefinite
-TESTS = Test_parser Test_tree Test_encoding crlf
+TESTS = Test_parser Test_tree Test_encoding Test_indefinite crlf
TESTS_ENVIRONMENT = \
ASN1PARSER=$(srcdir)/Test_parser.asn \
ASN1TREE=$(srcdir)/Test_tree.asn \
+ ASN1PKIX=$(srcdir)/pkix.asn \
+ ASN1PKIX=$(srcdir)/pkix.asn \
+ ASN1INDEF=$(srcdir)/TestIndef.p12 \
ASN1ENCODING=$(srcdir)/Test_encoding.asn \
$(VALGRIND)