summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2006-05-10 09:14:50 +0000
committerSimon Josefsson <simon@josefsson.org>2006-05-10 09:14:50 +0000
commit8b8d3e46c60e991bd08bba11ea6758c201efcd46 (patch)
tree9c80d4b4e57bbe83d08a5dae20803250cdd9cdb9 /tests/Makefile.am
parent319ddf6319d83d42f3402589893459735ba8597c (diff)
downloadlibtasn1-8b8d3e46c60e991bd08bba11ea6758c201efcd46.tar.gz
libtasn1-8b8d3e46c60e991bd08bba11ea6758c201efcd46.tar.bz2
libtasn1-8b8d3e46c60e991bd08bba11ea6758c201efcd46.zip
Add Test_encoding.
Simplify.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 34ed44f..268ffad 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,20 +20,18 @@
INCLUDES = -I../lib
AM_LDFLAGS = -no-install
+LDADD = ../lib/libtasn1.la
-EXTRA_DIST = Test_parser.asn Test_tree.asn Test_tree_asn1_tab.c
+EXTRA_DIST = Test_parser.asn Test_tree.asn Test_tree_asn1_tab.c \
+ Test_encoding.asn
-TESTS = Test_parser Test_tree
+TESTS = Test_parser Test_tree Test_encoding
check_PROGRAMS = $(TESTS)
-Test_parser_SOURCES = Test_parser.c
-Test_parser_LDADD = ../lib/libtasn1.la
-
-Test_tree_SOURCES = Test_tree.c
-Test_tree_LDADD = ../lib/libtasn1.la
VALGRIND=valgrind --leak-check=full --leak-resolution=high \
--show-reachable=yes --num-callers=50
TESTS_ENVIRONMENT = \
ASN1PARSER=$(srcdir)/Test_parser.asn \
ASN1TREE=$(srcdir)/Test_tree.asn \
+ ASN1ENCODING=$(srcdir)/Test_encoding.asn \
`if type valgrind > /dev/null 2>&1; then echo $(VALGRIND); else echo $$SHELL -c; fi`