summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2006-06-27 13:31:37 +0000
committerSimon Josefsson <simon@josefsson.org>2006-06-27 13:31:37 +0000
commit743292795dc5a3ea8a613ee561d872135c68b3c5 (patch)
tree90e847a622d15826ccaa17713cafb78ae7be6adc /tests/Makefile.am
parent8e3f42a96d9df7b25271ecae6eb04aba02bfced5 (diff)
downloadlibtasn1-743292795dc5a3ea8a613ee561d872135c68b3c5.tar.gz
libtasn1-743292795dc5a3ea8a613ee561d872135c68b3c5.tar.bz2
libtasn1-743292795dc5a3ea8a613ee561d872135c68b3c5.zip
Only optionally use valgrind.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 376cec1..a672cec 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -30,10 +30,8 @@ MOSTLYCLEANFILES = Test_parser_ERROR.asn
TESTS = Test_parser Test_tree Test_encoding
check_PROGRAMS = $(TESTS)
-VALGRIND=valgrind --tool=memcheck --leak-check=full --leak-resolution=high \
- --show-reachable=yes --num-callers=50
TESTS_ENVIRONMENT = \
ASN1PARSER=$(srcdir)/Test_parser.asn \
ASN1TREE=$(srcdir)/Test_tree.asn \
ASN1ENCODING=$(srcdir)/Test_encoding.asn \
- `if $(VALGRIND) /bin/true > /dev/null 2>&1; then echo $(VALGRIND); else echo $$SHELL -c; fi`
+ $(VALGRIND)